Closed Bug 1576846 Opened 3 months ago Closed 3 months ago

Crash in [@ mozilla::fontlist::FontList::Alloc]

Categories

(Core :: Layout: Text and Fonts, defect, P3, critical)

70 Branch
x86_64
Windows 7
defect

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed

People

(Reporter: over68, Assigned: jfkthame)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Crash Data

Attachments

(2 files)

Attached file testcase

Steps to reproduce:

  1. Set gfx.e10s.font-list.shared to true.
  2. Restart Firefox.
  3. Download Font Loader.
  4. Download Franklin Gothic Book Regular.ttf.
  5. Open the testcase.
  6. Open the Font Loader, Click on the Add Fonts button, Select the font file Franklin Gothic Book Regular.ttf then click Open.
  7. Click on the Load button then Unload.

Actual results:

The tab crashed.

Crash report: bp-bbd366f2-00a3-4ba1-8dba-071700190827

Top 10 frames of crashing thread:

0 xul.dll mozilla::fontlist::FontList::Alloc gfx/thebes/SharedFontList.cpp:607
1 xul.dll mozilla::fontlist::FontList::SetAliases gfx/thebes/SharedFontList.cpp:660
2 xul.dll void gfxPlatformFontList::CancelInitOtherFamilyNamesTask gfx/thebes/gfxPlatformFontList.cpp:2123
3 xul.dll gfxPlatformFontList::InitFontList gfx/thebes/gfxPlatformFontList.cpp:403
4 xul.dll gfxPlatformFontList::UpdateFontList gfx/thebes/gfxPlatformFontList.cpp:671
5 xul.dll gfxPlatform::UpdateFontList gfx/thebes/gfxPlatform.cpp:1742
6 xul.dll mozilla::dom::ContentChild::RecvRebuildFontList dom/ipc/ContentChild.cpp:2626
7 xul.dll mozilla::dom::PContentChild::OnMessageReceived ipc/ipdl/PContentChild.cpp:9539
8 xul.dll mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2108
9 xul.dll mozilla::ipc::MessageChannel::RunMessage ipc/glue/MessageChannel.cpp:1955

Huh - if I'm reading the crash report correctly, it looks like the content process is trying to do stuff that's supposed to be chrome-process-only.

Assignee: nobody → jfkthame
Flags: needinfo?(jfkthame)
Priority: -- → P3
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

This feature isn't enabled by default so I don't think we should worry about this for regression triage at this point.

Crash Signature: [@ mozilla::fontlist::FontList::Alloc] → [@ mozilla::fontlist::FontList::Alloc] [@ mozilla::fontlist::Family::FindAllFacesForStyle ]

I believe this should resolve the crash, at least for the original signature here; will test more locally after my Windows machine finishes updating itself.... (sigh).

Pushed by jkew@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3acfcd288f56
Fix the content-process's use of mAliasTable to temporarily record alternate font family names on Windows. r=jwatt
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.