Closed Bug 1577031 Opened 4 months ago Closed 3 months ago

Protection report: Shareable link

Categories

(Firefox :: Protections UI, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: ewright, Assigned: ewright)

References

Details

(Whiteboard: [protection-report][triage])

Attachments

(1 file)

We'd like to be able to share a link to the protection report.

  1. If a user is not on Firefox we'd like it to lead to a page giving a sample of the report and prompting a download.
  2. If the user is on an older version we'd like to lead them to a sample of the report and prompt them to upgrade.
  3. If a user is on 70+ Firefox it will lead to the report.

Step 1 and 2 will require building a website, this will be done elsewhere.

This bug is for implementing step 3, making about:protections link-able from external places.

Whiteboard: [protection-report][triage]

Erica, could you share the link when you have it so the marketing team and set up the moz.org redirect?

Thanks.
Cindy

Flags: needinfo?(ewright)

(In reply to chsiang from comment #1)

Erica, could you share the link when you have it so the marketing team and set up the moz.org redirect?

Thanks.
Cindy

I believe the link will simply be "about:protections", but I'll confirm that once it is functional.
(Unless you mean the link for the webpage, in that case marketing/moz.org team can pick whatever link they like, ex. mozilla.org/protection_report.)

Flags: needinfo?(ewright)

We should not make about:protections directly linkable, instead I'd prefer to provide a special JS API via UITour that allows the site to open the protection report. So the marketing team would have to integrate that into their site.

I think this more or less amounts to adding a new event type for opening the report here: https://searchfox.org/mozilla-central/rev/325c1a707819602feff736f129cb36055ba6d94f/browser/components/uitour/UITour.jsm#376

Assignee: nobody → ewright
Status: NEW → ASSIGNED

Hi Justin,
Erica can provide you the API for Whats New Page.

Flags: needinfo?(hoosteeno)

The websites team has an incoming request to build a landing page for the protection report. In order to make the protection report landing page shareable by all web users, we should not send anyone directly into browser UI upon landing there. Instead, all users will get a protection report marketing page, with a UA-switched CTA:

  • Fx <70 will be encouraged to update
  • Fx70+ will be encouraged to view their protection report
  • Non-Fx will be encouraged to download

We'll look in UITour docs for the appropriate API to accomplish the link. Thanks!

Flags: needinfo?(hoosteeno)
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4b003634e1a7
make Protection Report page sharable via UITour. r=johannh
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Why did this reach central?

Flags: needinfo?(dluca)

I'm not sure, I think it wasn't very frequent in the beginning and just got merged.

Status: RESOLVED → REOPENED
Flags: needinfo?(dluca)
Resolution: FIXED → ---
Target Milestone: Firefox 71 → ---

I think I know why this happened, the RPM is trying to communicate with about:protections after it is gone - we've had similar things happen with this page in other tests. Waiting on a try build to finish.

Flags: needinfo?(ewright)
Regressions: 1578799
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e6aaee8a6695
make Protection Report page sharable via UITour. r=johannh
Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9089506 [details]
Bug 1577031 - make Protection Report page sharable via UITour.

Beta/Release Uplift Approval Request

  • User impact if declined: This makes the about:protections page linkable. We can now share a link for marketing purposes, we will be linking to it from the what's new page and from moz.org. We'd like to do that with the 70 release in conjunction with Skyline efforts.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): fairly simple patch, has a test, repeating a pattern already implemented for the about:newtab page.
  • String changes made/needed: none
Attachment #9089506 - Flags: approval-mozilla-beta?

Comment on attachment 9089506 [details]
Bug 1577031 - make Protection Report page sharable via UITour.

Makes about:protections linkable/sharable. Support for Skyline.
OK for beta uplift (beta 6)

Attachment #9089506 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Can you help me with some way to verify the change? Thanks.

Flags: needinfo?(ewright)

(In reply to Bodea Daniel [:danibodea] from comment #20)

Can you help me with some way to verify the change? Thanks.

Sure, open a browser console and type in UITour.showProtectionReport(window). It should behave in the same way that UITour.showNewTab(window) does, except opening about:protections rather than about:newtab.

Flags: needinfo?(ewright)

Using the "UITour.showProtectionReport(window)" command in Browser Console does the exact same thing as opening the "about:protections" page.

Nightly v70.0a1 from 2019-09-15 and Beta v70.0b6 builds show the Privacy Protections section (that contains the current Protection Level and a report of the blocked trackers in the last week), the "Look out for data breaches" section with the "Sign Up for Breach Alerts" button and the "Never forget a password again" section with the "View Logins" button and an encouragement to use the Lockwise app.

The Release v69.0 build also opens the same page that shows the Privacy Protections section (that contains the current Protection Level and a report of the blocked trackers in the last week), but does NOT show the "Look out for data breaches" section or the "Never forget a password again" section.

I will assume that this is the intended/expected behavior after the implementation and set the bug's status as VERIFIED. Please confirm that this is the expected result. Thank you.

Status: RESOLVED → VERIFIED
Flags: qe-verify+ → needinfo?(ewright)

(In reply to Bodea Daniel [:danibodea] from comment #22)

Using the "UITour.showProtectionReport(window)" command in Browser Console does the exact same thing as opening the "about:protections" page.

Nightly v70.0a1 from 2019-09-15 and Beta v70.0b6 builds show the Privacy Protections section (that contains the current Protection Level and a report of the blocked trackers in the last week), the "Look out for data breaches" section with the "Sign Up for Breach Alerts" button and the "Never forget a password again" section with the "View Logins" button and an encouragement to use the Lockwise app.

The Release v69.0 build also opens the same page that shows the Privacy Protections section (that contains the current Protection Level and a report of the blocked trackers in the last week), but does NOT show the "Look out for data breaches" section or the "Never forget a password again" section.

I will assume that this is the intended/expected behavior after the implementation and set the bug's status as VERIFIED. Please confirm that this is the expected result. Thank you.

Thank you for testing this. The function UITour.showProtectionReport(window) is the part of this bug that needed to be tested. At the moment, this function is not being used anywhere, but it will be used by Moz.org and our whats new page soon. about:protections existing in 69 as well as 70 and 71 is also expected.

Flags: needinfo?(ewright)
You need to log in before you can comment on or make changes to this bug.