Closed Bug 1577148 Opened 3 months ago Closed 2 months ago

The "What's New Panel" links can't be opened with the "Enter" key

Categories

(Firefox :: Messaging System, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 + verified
firefox71 --- verified

People

(Reporter: mcoman, Assigned: andreio)

References

Details

(Keywords: access, Whiteboard: [access-p1])

Attachments

(2 files)

Attached image rec of the issue.gif

[Affected versions]:

  • Firefox Nightly 70.0a1 - Build ID: 20190827203416

[Affected Platforms]:

  • All Windows
  • All Linux
  • All Mac

[Prerequisites]:

  • Have a new Firefox profile with the following pref's in the "about:config" page:
    • "browser.newtabpage.activity-stream.asrouter.providers.panel_local_testing" set to "{"id":"panel_local_testing", "cohort": "SHOW_TEST"}"
    • "browser.messaging-system.whatsNewPanel.enabled" set to "true"
    • "browser.newtabpage.activity-stream.asrouter.devtoolsEnabled" set to "true"

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites and navigate to "about:newtab#devtools".
  2. Select the "panel_local_testing" from the "Messages" section's filter.
  3. Scroll down to the "WHATS_NEW_BADGE_70" section and click the "Show" button.
  4. Click the "What's New" toolbar button and press the "Tab" key two times.
  5. Press the "Enter" key and observe the behavior.

[Expected result]:

[Actual result]:

  • Nothing happens.

[Notes]:

  • This issue is not reproducible if the link is clicked instead.
  • Attached a screen recording of the issue.

Messages can be accessed with both Enter and Space
Links can only be accessed with Space (Enter does not work)

Priority: -- → P3

Can you try to fix this for 70? Since this affects accessibility I'd like for us to make it a priority.

Flags: needinfo?(tspurway)
Keywords: access

Initially we thought that accessing links via keyboard navigation didn't work at all in the panel, but as :andreio found out it's just the "Enter" key that doesn't work. The "Space" key still works as expected in this case. I've updated the Summary to reflect this.

@Liz, given that we have an easy work around for the issue, do we still consider this important for Fx 70, or can it be pushed to a future release?

Flags: needinfo?(lhenry)
Summary: The "What's New Panel" links cannot be opened through keyboard navigation → The "What's New Panel" links can't be opened with the "Enter" key

This is definitely an inconsistent behavior for keyboard users, since the standard way to open links is Enter, not Space. This should be dealt with with a P2 rather than a P3 I think, although for 70, even though unpolished, an uplift may be debatable. But remember that for keyboard users, Space to activate links is non-standard and thus not easily discoverable.

Flags: needinfo?(cmuresan)
Flags: needinfo?(andrei.br92)

Making this a P2.

Flags: needinfo?(cmuresan)
Flags: needinfo?(andrei.br92)
Priority: P3 → P2
Assignee: nobody → andrei.br92
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c74e1d89a83c
Open What's New Panel message links with the keyboard r=pdahiya
Whiteboard: [access-p1]
See Also: → 1582061
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9093299 [details]
Bug 1577148 - Open What's New Panel message links with the keyboard

Beta/Release Uplift Approval Request

  • User impact if declined: Accessibility issues for What's New Panel
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open the What's New panel
    <Tab> to focus on
    a) a what's new message
    b) a what's new message link
    Use <Enter> to access. A new tab should open with the url
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small code chage
  • String changes made/needed: n/a
Attachment #9093299 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Please help verify this. There is a separate issue covering <Space> key access opening two tabs (bug 1582061). Since that is not the expected key (comment 4) fixing it can happen in a follow up bug.

Flags: needinfo?(mcoman)

Comment on attachment 9093299 [details]
Bug 1577148 - Open What's New Panel message links with the keyboard

a11y improvements for the What's New Panel. Approved for 70.0b8.

Attachment #9093299 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I have verified that this issue is no longer reproducible with the latest Firefox Nightly (71.0a1 Build ID - 20190918215055) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, the "What's New Panel" links can be opened with the "Enter" key.

Status: RESOLVED → VERIFIED
Flags: needinfo?(mcoman)
Flags: needinfo?(tspurway)
Flags: needinfo?(lhenry)

I have verified that this issue is no longer reproducible with the latest Firefox Beta (70.0b8 Build ID - 20190919164641) installed, on Windows 10 x64, Arch Linux and Mac 10.14.5. Now, the "What's New Panel" links can be opened with the "Enter" key.

Flags: qe-verify+

Thank you!

You need to log in before you can comment on or make changes to this bug.