Closed Bug 1577180 Opened 5 months ago Closed 5 months ago

Perma TEST-UNEXPECTED-FAIL | browser/components/aboutlogins/tests/unit/test_getPotentialBreachesByLoginGUID.js | xpcshell return code: 0 when Gecko 70 merges to Beta on 2019-08-26

Categories

(Toolkit :: Password Manager, defect, P1, major)

defect

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 blocking verified

People

(Reporter: bogdan_tara, Assigned: MattN)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [rca - Testing Error])

Attachments

(1 file)

Central as Beta simulation:
https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=263855977&revision=054cba7223bc44f9e4bea4a788e9b0854602feae&searchStr=windows%2C7%2Cdebug%2Cxpcshell%2Ctests%2Ctest-windows7-32%2Fdebug-xpcshell-e10s-1%2Cx%28x1%29

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=263855977&repo=try&lineNumber=6201

https://taskcluster-artifacts.net/GULl2zbHQOOQbM-i3KU8Xw/0/public/logs/live_backing.log

[task 2019-08-28T12:48:47.217Z] 12:48:47 INFO - TEST-START | netwerk/test/unit/test_bug767025.js
[task 2019-08-28T12:48:47.836Z] 12:48:47 INFO - TEST-PASS | netwerk/test/unit/test_bug767025.js | took 619ms
[task 2019-08-28T12:48:47.871Z] 12:48:47 INFO - Retrying tests that failed when run in parallel.
[task 2019-08-28T12:48:47.886Z] 12:48:47 INFO - TEST-START | browser/components/aboutlogins/tests/unit/test_getPotentialBreachesByLoginGUID.js
[task 2019-08-28T12:48:48.201Z] 12:48:48 WARNING - TEST-UNEXPECTED-FAIL | browser/components/aboutlogins/tests/unit/test_getPotentialBreachesByLoginGUID.js | xpcshell return code: 0
[task 2019-08-28T12:48:48.201Z] 12:48:48 INFO - TEST-INFO took 316ms
[task 2019-08-28T12:48:48.202Z] 12:48:48 INFO - >>>>>>>
[task 2019-08-28T12:48:48.202Z] 12:48:48 INFO - PID 5764 | [5764, Main Thread] WARNING: Failed to get directory to cache.: file z:/build/build/src/security/sandbox/win/src/sandboxbroker/sandboxBroker.cpp, line 83
[task 2019-08-28T12:48:48.202Z] 12:48:48 INFO - PID 5764 | [5764, Main Thread] WARNING: Failed to get directory to cache.: file z:/build/build/src/security/sandbox/win/src/sandboxbroker/sandboxBroker.cpp, line 83
[task 2019-08-28T12:48:48.202Z] 12:48:48 INFO - PID 5764 | [5764, Main Thread] WARNING: Failed to get directory to cache.: file z:/build/build/src/security/sandbox/win/src/sandboxbroker/sandboxBroker.cpp, line 83
[task 2019-08-28T12:48:48.202Z] 12:48:48 INFO - PID 5764 | [5764, Main Thread] WARNING: Failed to get directory to cache.: file z:/build/build/src/security/sandbox/win/src/sandboxbroker/sandboxBroker.cpp, line 83
[task 2019-08-28T12:48:48.202Z] 12:48:48 INFO - PID 5764 | [5764, Main Thread] WARNING: Failed to get directory to cache.: file z:/build/build/src/security/sandbox/win/src/sandboxbroker/sandboxBroker.cpp, line 83
[task 2019-08-28T12:48:48.202Z] 12:48:48 INFO - PID 5764 | [5764, Main Thread] WARNING: Couldn't get the user appdata directory. Crash events may not be produced.: file z:/build/build/src/toolkit/crashreporter/nsExceptionHandler.cpp, line 2632
[task 2019-08-28T12:48:48.202Z] 12:48:48 INFO - PID 5764 | JavaScript error: resource://gre/modules/XULStore.jsm, line 66: Error: Can't find profile directory.
[task 2019-08-28T12:48:48.202Z] 12:48:48 INFO - PID 5764 | JavaScript error: resource://gre/modules/XPCOMUtils.jsm, line 215: NS_ERROR_XPC_GS_RETURNED_FAILURE: ServiceManager::GetService returned failure code:
[task 2019-08-28T12:48:48.202Z] 12:48:48 INFO - NS_ERROR_XPC_GS_RETURNED_FAILURE: ServiceManager::GetService returned failure code:
[task 2019-08-28T12:48:48.203Z] 12:48:48 INFO - @Z:/task_1566992875/build/tests/xpcshell/tests/browser/components/aboutlogins/tests/unit/test_getPotentialBreachesByLoginGUID.js:11:63
[task 2019-08-28T12:48:48.203Z] 12:48:48 INFO - load_file@Z:\task_1566992875\build\tests\xpcshell\head.js:682:11
[task 2019-08-28T12:48:48.203Z] 12:48:48 INFO - _load_files@Z:\task_1566992875\build\tests\xpcshell\head.js:694:10
[task 2019-08-28T12:48:48.203Z] 12:48:48 INFO - _execute_test@Z:\task_1566992875\build\tests\xpcshell\head.js:545:14
[task 2019-08-28T12:48:48.203Z] 12:48:48 INFO - @-e:1:14
[task 2019-08-28T12:48:48.203Z] 12:48:48 INFO - (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2019-08-28T12:48:48.203Z] 12:48:48 INFO - PID 5764 | [5764, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, kKnownEsrVersion) failed with result 0x80004002: file z:/build/build/src/toolkit/components/resistfingerprinting/nsRFPService.cpp, line 662
[task 2019-08-28T12:48:48.203Z] 12:48:48 INFO - PID 5764 | [5764, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file z:/build/build/src/extensions/permissions/nsPermissionManager.cpp, line 2857
[task 2019-08-28T12:48:48.203Z] 12:48:48 INFO - (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2019-08-28T12:48:48.203Z] 12:48:48 INFO - (xpcshell/head.js) | test MAIN run_test finished (2)

MattN, could you, please, take a look?

Flags: needinfo?(MattN+bmo)

I should have a fix today.

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(MattN+bmo)

Tracking as a blocker for the beta merge.

Priority: -- → P1

Hmm… so this is only failing on Windows which is unusual since I see other tests using the same pattern.

I'm not sure of the exact cause since that would require doing a local Windows beta build and the getService error doesn't indicate what failed inside the component. I mostly guessed that this was the problem by looking at other tests which do the same thing.

Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/716ad5a4347e
Get a profile before accessing BrowserGlue in test_getPotentialBreachesByLoginGUID.js. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

This bug has been identified as part of a pilot on determining root causes of blocking and dot release drivers.

It needs a root-cause set for it. Please see the list at https://docs.google.com/document/d/1FFEGsmoU8T0N8R9kk-MXWptOPtXXXRRIe4vQo3_HgMw/.

Add the root cause as a whiteboard tag in the form [rca - <cause> ] and remove the rca-needed keyword.

If you have questions, please contact :tmaity.

Keywords: rca-needed
Keywords: rca-needed
Whiteboard: [rca - Testing Error]
You need to log in before you can comment on or make changes to this bug.