crashed with X windows-related error message

RESOLVED DUPLICATE of bug 85958

Status

()

RESOLVED DUPLICATE of bug 85958
17 years ago
17 years ago

People

(Reporter: scottamcmullen, Assigned: Matti)

Tracking

({crash, stackwanted})

Trunk
Sun
Solaris
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.0) Gecko/20020611
BuildID:    2002061103

when i try to access certain web pages, i get an X window system related crash.
i am running solaris 8:

[sparc:august:] uname -a
SunOS august 5.8 Generic_108528-12 sun4u sparc SUNW,Ultra-5_10

the mozilla session crashes, and this message is emitted to stdout (or stderr):

[sparc:august:] X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  131 (MIT-SHM)
  Minor opcode of failed request:  3 (X_ShmPutImage)
  Serial number of failed request:  64
  Current serial number in output stream:  64

i run mozilla 1.0 on my red hat linux 6.2 (i586) system at home, and
haven't observed this error on it, so i think it's related to the
solaris version only.



Reproducible: Always
Steps to Reproduce:
1.start mozilla (i am using the Classic theme)
2.type in url: http://www.snapgear.com
3. mozilla session crashes, with X window system related message.

Actual Results:  this message is emitted to stdout (or possibly stderr) from the
window in which i launched mozilla:

[sparc:august:] X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  131 (MIT-SHM)
  Minor opcode of failed request:  3 (X_ShmPutImage)
  Serial number of failed request:  64
  Current serial number in output stream:  64


Expected Results:  displayed the page at the snapgear web site.

i've observed this crash at several other web sites as well.

opera 5 on the solaris 8 system is able to render this site 
(snapgear) okay also.

Updated

17 years ago
Keywords: crash, stackwanted
Summary: creashed with X windows-related error message → crashed with X windows-related error message

Comment 1

17 years ago
In run-mozilla.sh, look for a line with XSUNTRANSPORT="shmem",
set this line to XSUNTRANSPORT="noshmem" and comment out
the next one (XSUNSMESIZE="512"). Then this problem should
not occur again. This is a duplicate of a well known problem, forgot
the bug number.

Comment 2

17 years ago
This a Flash-related bug which has been fixed in recently nightlies. Its a
duplicate of bug 85958.

*** This bug has been marked as a duplicate of 85958 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: Browser-General → Plug-ins
QA Contact: asa
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.