Closed Bug 1577359 Opened 2 months ago Closed Last month

Build atob and btoa for Thunderbird

Categories

(NSS :: Test, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kaie, Assigned: kaie)

Details

Attachments

(2 files, 1 obsolete file)

Build atob and btoa when building NSS for Thunderbird.

Attached patch 1577359.patchSplinter Review

Do simply patches still work, or are we required to go through phabricator?

Assignee: nobody → kaie
Attachment #9088901 - Flags: review?(jjones)
Comment on attachment 9088901 [details] [diff] [review]
1577359.patch

Review of attachment 9088901 [details] [diff] [review]:
-----------------------------------------------------------------

They still work fine for NSS and NSPR. It's becoming impossible to land except via Phabricator/Lando in mozilla-central though.
Attachment #9088901 - Flags: review?(jjones) → review+

Thanks J.C.! Setting checkin reminder for myself, for after the current freeze.

Flags: needinfo?(kaie)
Status: NEW → RESOLVED
Closed: Last month
Flags: needinfo?(kaie)
Resolution: --- → FIXED
Target Milestone: --- → 3.47

This merged in bug 1577822 and now Mac builds are busted :-(

make[4]: *** [../../../../../dist/bin/btoa] Error 1
make[3]: *** [security/nss/cmd/btoa/btoa_btoa/target] Error 2

Flags: needinfo?(kaie)
Flags: needinfo?(jjones)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Correction: Mac and Windows builds, so it took out two of our three platforms and technically I'd have to close the tree now.

Mac builds of Thunderbird?

Flags: needinfo?(jjones) → needinfo?(jorgk)

Can you point us to a log?

[task 2019-09-19T07:42:40.963Z] 07:42:40 INFO - Undefined symbols for architecture x86_64:
[task 2019-09-19T07:42:40.963Z] 07:42:40 INFO - "_NSSBase64Encoder_Create_Util", referenced from:
[task 2019-09-19T07:42:40.963Z] 07:42:40 INFO - _main in btoa.o
[task 2019-09-19T07:42:40.963Z] 07:42:40 INFO - "_NSSBase64Encoder_Update_Util", referenced from:
[task 2019-09-19T07:42:40.963Z] 07:42:40 INFO - _main in btoa.o
[task 2019-09-19T07:42:40.963Z] 07:42:40 INFO - "_NSSBase64Encoder_Destroy_Util", referenced from:
[task 2019-09-19T07:42:40.963Z] 07:42:40 INFO - _main in btoa.o

Sorry, I didn't except this to happen. I should have made a try build of Thunderbird on all platforms.

I think it will be sufficient to add entries to comm/mailnews/nss-extra.symbols

Flags: needinfo?(kaie)

This is a patch for comm-central, I haven't yet tested it, and I don't have a curent local build, so I cannot test it quickly. Should we attempt to check it in, or do you want to wait for me to have a verified fix?

Attachment #9093840 - Flags: review?(jorgk)

Surprisingly the original patch with the encoder symbols doesn't work, but this one does.

Attachment #9093847 - Flags: review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/d4028b82f6b6
Follow-up: Add NSSBase64Decoder_* symbols to nss-extra.symbols. r=jorgk

Status: REOPENED → RESOLVED
Closed: Last monthLast month
Resolution: --- → FIXED
Comment on attachment 9093840 [details] [diff] [review]
1577359-winmac.patch

Sigh, still doesn't work on Mac with the decoder symbols although I carefully checked that Windows and Mac had the same error messages. I'll land this, too.
Attachment #9093840 - Flags: review?(jorgk) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/17dd60cb1d5c
Follow-up: Add NSSBase64Encoder_* symbols to nss-extra.symbols. r=jorgk
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/220b3257a60a
Follow-up: remove NSSBase64Decoder_* symbols again. r=me DONTBUILD

Well, the push with the decoder symbols added didn't work, but it did work locally, unless I messed up.
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=d4028b82f6b6fd19d41fe0cc45ab6482f5c53d52
I've taken them out again.

I tried to retrace the steps that led to the faulty results. All I can say is that changing mailnews/nss-extra.symbols doesn't trigger a re-make of the dependent targets. Right now I've remove all NSSBase64XXcoder_* symbols again locally and it still compiles. Since Kai's original patch works for Mac in automation (Windows not done yet), we're done here. Sorry about the noise.

Comment on attachment 9093847 [details] [diff] [review]
1577359-winmac.patch - with decoder symbols

That appeared to fix the problem locally, but as I wrote, not so easy to tell, see previous comment.
Attachment #9093847 - Attachment is obsolete: true
Attachment #9093847 - Flags: review+

Jörg, one tool does encoding, the other does decoding. The build might have stopped building after the first failure. It's possible that all those symbols are required. With some symbols backed out, one of the tools might again fail to build.

I'll submit a try build for win and mac with the current state of comm-central. Let's see if it fails. If it does, we might have to reland those symbols.

Yes, thanks. The successful Daily was built with both sets (decode/encode). Let's see what happens after the decode backout.

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/344aca0c9c42
Follow-up: Add NSSBase64Decoder_* symbols to nss-extra.symbols (again). r=jorgk DONTBUILD

That try failed, so the decode symbols are needed after all. Finally done here.

You need to log in before you can comment on or make changes to this bug.