Closed Bug 1577663 Opened 4 months ago Closed 4 months ago

[Card Grid] Remove ds-header if empty and margin tweaks

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 70
Iteration:
70.4 - Aug 19 - Sep 1
Tracking Status
firefox70 --- verified

People

(Reporter: wolasi, Assigned: thecount)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(1 file)

Please make the following changes

  • Remove the following CSS rule…
.collapsible-section.ds-layout .section-top-bar {
    margin-bottom: 0;
}
  • Do not render <div class="ds-header"></div> if there is not content

  • Remove margins on .ds-card-grid

This is probably pretty easy fix. Might be worth trying to get in today.

Assignee: nobody → sdowne
Priority: -- → P1
Blocks: 1577888
Status: NEW → RESOLVED
Iteration: --- → 70.4 - Aug 19 - Sep 1
Closed: 4 months ago
Keywords: github-merged
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70

As I was trying to verify this issue I noticed that the margin-bottom for the .section-top-bar from the collapsible-section now has a value of 13px.
@Scott Was this change intended?
The margin for the .ds-card-grid is properly removed and no longer displayed.

Flags: needinfo?(sdowne)

Yes, that change was intended.

Flags: needinfo?(sdowne)

I have verified this issue on Latest Firefox Nightly 71.0a1 (Build ID: 20190902213933) on Windows 10 x64, Mac 10.14.5 and Arch Linux 4.16.6 x64.
The margin for the .ds-card-grid is properly removed and no longer displayed and considering the Comment 5
the margin-bottom for the .section-top-bar from the collapsible-section has a value of 13px as expected.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.