Closed Bug 1577723 Opened 1 year ago Closed 1 year ago

Intermittent fission [tier 2] dom/tests/mochitest/dom-level0/test_location.html | Test timed out.

Categories

(Core :: DOM: Core & HTML, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Fission Milestone M4
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- disabled
firefox71 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: kmag)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell unknown])

Attachments

(1 file)

Filed by: shindli [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=264184374&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/EaDh_JHwScWh3qkPhBkCLA/runs/0/artifacts/public/logs/live_backing.log


[task 2019-08-30T05:35:01.193Z] 05:35:01 INFO - GECKO(4163) | --DOMWINDOW == 0 (0x7f09e8967800) [pid = 4378] [serial = 2] [outer = (nil)] [url = about:blank]
[task 2019-08-30T05:35:01.209Z] 05:35:01 INFO - GECKO(4163) | [Child 4378, Main Thread] WARNING: Extra shutdown CC: 'i < NORMAL_SHUTDOWN_COLLECTIONS', file /builds/worker/workspace/build/src/xpcom/base/nsCycleCollector.cpp, line 3361
[task 2019-08-30T05:35:01.236Z] 05:35:01 INFO - GECKO(4163) | nsStringStats
[task 2019-08-30T05:35:01.237Z] 05:35:01 INFO - GECKO(4163) | => mAllocCount: 5867
[task 2019-08-30T05:35:01.237Z] 05:35:01 INFO - GECKO(4163) | => mReallocCount: 0
[task 2019-08-30T05:35:01.237Z] 05:35:01 INFO - GECKO(4163) | => mFreeCount: 5867
[task 2019-08-30T05:35:01.238Z] 05:35:01 INFO - GECKO(4163) | => mShareCount: 3180
[task 2019-08-30T05:35:01.238Z] 05:35:01 INFO - GECKO(4163) | => mAdoptCount: 183
[task 2019-08-30T05:35:01.238Z] 05:35:01 INFO - GECKO(4163) | => mAdoptFreeCount: 185
[task 2019-08-30T05:35:01.238Z] 05:35:01 INFO - GECKO(4163) | => Process ID: 4378, Thread ID: 139680983590720
[task 2019-08-30T05:35:01.314Z] 05:35:01 INFO - GECKO(4163) | MEMORY STAT | vsize 2520MB | residentFast 147MB | heapAllocated 13MB
[task 2019-08-30T05:35:01.395Z] 05:35:01 INFO - GECKO(4163) | JavaScript error: resource:///modules/UrlbarInput.jsm, line 207: TypeError: this._inputFieldEvents is undefined
[task 2019-08-30T05:35:01.416Z] 05:35:01 INFO - TEST-OK | dom/tests/mochitest/dom-level0/test_innerWidthHeight_script.html | took 1084ms
[task 2019-08-30T05:35:01.472Z] 05:35:01 INFO - GECKO(4163) | ++DOMWINDOW == 14 (0x7f50aadecc00) [pid = 4323] [serial = 21] [outer = 0x7f50adf9b100]
[task 2019-08-30T05:35:01.500Z] 05:35:01 INFO - TEST-START | dom/tests/mochitest/dom-level0/test_location.html
[task 2019-08-30T05:35:01.568Z] 05:35:01 INFO - GECKO(4163) | ++DOMWINDOW == 15 (0x7f50aadf7800) [pid = 4323] [serial = 22] [outer = 0x7f50adf9b100]
[task 2019-08-30T05:35:01.609Z] 05:35:01 INFO - GECKO(4163) | --DOMWINDOW == 14 (0x7f50ae0d1800) [pid = 4323] [serial = 7] [outer = (nil)] [url = http://mochi.test:8888/tests/dom/tests/mochitest/dom-level0/test_background_loading_iframes.html]
[task 2019-08-30T05:35:01.610Z] 05:35:01 INFO - GECKO(4163) | --DOMWINDOW == 13 (0x7f50aad30000) [pid = 4323] [serial = 11] [outer = (nil)] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
[task 2019-08-30T05:35:01.611Z] 05:35:01 INFO - GECKO(4163) | --DOCSHELL 0x7f50aad62800 == 2 [pid = 4323] [id = {99339cf7-d2a6-4f99-9897-06668b393698}] [url = http://mochi.test:8888/tests/dom/tests/mochitest/dom-level0/innerWidthHeight_script.html]
[task 2019-08-30T05:35:01.627Z] 05:35:01 INFO - GECKO(4163) | ++DOCSHELL 0x7f50aad68800 == 3 [pid = 4323] [id = {57af7b06-5afd-458a-a3a0-5ac8ee03c116}]
[task 2019-08-30T05:35:01.628Z] 05:35:01 INFO - GECKO(4163) | ++DOMWINDOW == 14 (0x7f50adf9b880) [pid = 4323] [serial = 23] [outer = (nil)]
[task 2019-08-30T05:35:01.629Z] 05:35:01 INFO - GECKO(4163) | ++DOMWINDOW == 15 (0x7f50aad30000) [pid = 4323] [serial = 24] [outer = 0x7f50adf9b880]
[task 2019-08-30T05:35:01.705Z] 05:35:01 INFO - GECKO(4163) | ++DOMWINDOW == 16 (0x7f50adf11400) [pid = 4323] [serial = 25] [outer = 0x7f50adf9b880]
[task 2019-08-30T05:35:01.733Z] 05:35:01 INFO - GECKO(4163) | --DOMWINDOW == 15 (0x7f50adf9b2e0) [pid = 4323] [serial = 13] [outer = (nil)] [url = http://mochi.test:8888/tests/dom/tests/mochitest/dom-level0/file_crossdomainprops_inner.html]
[task 2019-08-30T05:35:01.749Z] 05:35:01 INFO - GECKO(4163) | [Child 4323, Main Thread] WARNING: CompleteRedirectSetup failed, HttpChannelChild already open?: file /builds/worker/workspace/build/src/netwerk/protocol/http/HttpChannelChild.cpp, line 2125
[task 2019-08-30T05:35:01.825Z] 05:35:01 INFO - GECKO(4163) | ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /tmp/tmpjyF2TS.mozrunner/runtests_leaks_tab_pid4400.log
[task 2019-08-30T05:35:01.885Z] 05:35:01 INFO - GECKO(4163) | --DOCSHELL 0x7f50aad68800 == 2 [pid = 4323] [id = {57af7b06-5afd-458a-a3a0-5ac8ee03c116}] [url = http://mochi.test:8888/tests/dom/tests/mochitest/dom-level0/file_location.html]
[task 2019-08-30T05:35:01.886Z] 05:35:01 INFO - GECKO(4163) | --DOMWINDOW == 14 (0x7f50aad2d000) [pid = 4323] [serial = 12] [outer = (nil)] [url = http://mochi.test:8888/tests/dom/tests/mochitest/dom-level0/test_crossdomainprops.html]
[task 2019-08-30T05:35:01.887Z] 05:35:01 INFO - GECKO(4163) | --DOMWINDOW == 13 (0x7f50adf11800) [pid = 4323] [serial = 15] [outer = (nil)] [url = http://mochi.test:8888/tests/dom/tests/mochitest/dom-level0/file_crossdomainprops_inner.html]
[task 2019-08-30T05:35:01.888Z] 05:35:01 INFO - GECKO(4163) | --DOMWINDOW == 12 (0x7f50aadea000) [pid = 4323] [serial = 19] [outer = (nil)] [url = about:blank]
[task 2019-08-30T05:35:01.888Z] 05:35:01 INFO - GECKO(4163) | --DOMWINDOW == 11 (0x7f50ae0cdc00) [pid = 4323] [serial = 16] [outer = (nil)] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
[task 2019-08-30T05:35:01.964Z] 05:35:01 INFO - GECKO(4163) | Couldn't convert chrome URL: chrome://branding/locale/brand.properties
[task 2019-08-30T05:35:02.000Z] 05:35:02 INFO - GECKO(4163) | --DOMWINDOW == 10 (0x7f50adf9b4c0) [pid = 4323] [serial = 18] [outer = (nil)] [url = http://mochi.test:8888/tests/dom/tests/mochitest/dom-level0/innerWidthHeight_script.html]
[task 2019-08-30T05:35:02.060Z] 05:35:02 INFO - GECKO(4163) | --DOMWINDOW == 9 (0x7f50aad34000) [pid = 4323] [serial = 17] [outer = (nil)] [url = http://mochi.test:8888/tests/dom/tests/mochitest/dom-level0/test_innerWidthHeight_script.html]
[task 2019-08-30T05:35:02.061Z] 05:35:02 INFO - GECKO(4163) | --DOMWINDOW == 8 (0x7f50aadecc00) [pid = 4323] [serial = 21] [outer = (nil)] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
[task 2019-08-30T05:35:02.062Z] 05:35:02 INFO - GECKO(4163) | --DOMWINDOW == 7 (0x7f50aaded400) [pid = 4323] [serial = 20] [outer = (nil)] [url = about:blank]
[task 2019-08-30T05:35:02.098Z] 05:35:02 INFO - GECKO(4163) | WARN 2019-08-30T05:35:02Z: audio_thread_priority::rt_linux: Could not make thread real-time.
[task 2019-08-30T05:35:02.098Z] 05:35:02 INFO - GECKO(4163) | WARN 2019-08-30T05:35:02Z: audioipc_client: Could not promote audio threads to real-time during initialization.
[task 2019-08-30T05:35:02.105Z] 05:35:02 INFO - GECKO(4163) | ++DOCSHELL 0x7fbe0aab8000 == 1 [pid = 4400] [id = {4d1eba07-9c0f-4c77-9a9a-46b5f94edc15}]
[task 2019-08-30T05:35:02.147Z] 05:35:02 INFO - GECKO(4163) | ++DOMWINDOW == 1 (0x7fbe0b9daf20) [pid = 4400] [serial = 1] [outer = (nil)]
[task 2019-08-30T05:35:02.148Z] 05:35:02 INFO - GECKO(4163) | ++DOMWINDOW == 2 (0x7fbe0aa64800) [pid = 4400] [serial = 2] [outer = 0x7fbe0b9daf20]
[task 2019-08-30T05:35:02.189Z] 05:35:02 INFO - GECKO(4163) | ++DOMWINDOW == 3 (0x7fbe0b909800) [pid = 4400] [serial = 3] [outer = 0x7fbe0b9daf20]
[task 2019-08-30T05:35:02.491Z] 05:35:02 INFO - GECKO(4163) | --DOCSHELL 0x7fd648e4c000 == 7 [pid = 4163] [id = {a852f7c6-abd0-4470-92d0-ce427a54a83b}] [url = about:blank]
[task 2019-08-30T05:35:08.849Z] 05:35:08 INFO - GECKO(4163) | --DOCSHELL 0x7fd6490dc000 == 6 [pid = 4163] [id = {02c3c970-9435-485c-97e2-9d7306bbf0cd}] [url = about:blank]
[task 2019-08-30T05:35:08.849Z] 05:35:08 INFO - GECKO(4163) | --DOCSHELL 0x7fd647628000 == 5 [pid = 4163] [id = {5f80eafb-f643-418a-a6dd-48b7396334e1}] [url = chrome://browser/content/browser.xhtml]
[task 2019-08-30T05:35:09.111Z] 05:35:09 INFO - GECKO(4163) | --DOMWINDOW == 15 (0x7fd64c8fac40) [pid = 4163] [serial = 16] [outer = (nil)] [url = about:blank]
[task 2019-08-30T05:35:09.111Z] 05:35:09 INFO - GECKO(4163) | --DOMWINDOW == 14 (0x7fd64c8faa60) [pid = 4163] [serial = 15] [outer = (nil)] [url = about:blank]
[task 2019-08-30T05:35:09.112Z] 05:35:09 INFO - GECKO(4163) | --DOMWINDOW == 13 (0x7fd64c8fa880) [pid = 4163] [serial = 13] [outer = (nil)] [url = chrome://browser/content/browser.xhtml]
[task 2019-08-30T05:35:13.058Z] 05:35:13 INFO - GECKO(4163) | --DOMWINDOW == 12 (0x7fd64423e400) [pid = 4163] [serial = 14] [outer = (nil)] [url = about:blank]

Hsin-Yi, this is failing constantly on fission since the 30th of august, wanna redirect this to someone who can fix this on fission or can we disable it? Thank you.
Recent failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=266634219&repo=mozilla-central

Flags: needinfo?(htsai)
Summary: Intermittent dom/tests/mochitest/dom-level0/test_location.html | Test timed out. → Intermittent fission [tier 2] dom/tests/mochitest/dom-level0/test_location.html | Test timed out.

Hi kmag,
Should we Mark as skip now?

Flags: needinfo?(htsai) → needinfo?(kmaglione+bmo)
Assignee: nobody → kmaglione+bmo
Flags: needinfo?(kmaglione+bmo)

Storing a DocShell rather than a BrowsingContext causes a number of problems
when dealing with cross-process navigations. The most immediate in this case
is that some cross-origin-allowed operations only work after a local-to-remote
navigation only until the original DocShell is destroyed, which causes
intermittent test failures.

It also means, though, that after a local-to-remote navigation, where the
DocShell has not been destroyed, attempts to read same-origin properties still
end up at the old DocShell, and as a result, lie about the current state of
the BrowsingContext.

Status: NEW → ASSIGNED
Fission Milestone: --- → M4
Priority: -- → P2
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6d1a9a57c526
Store BrowsingContext ID in dom::Location rather than DocShell weak reference. r=farre
https://hg.mozilla.org/integration/mozilla-inbound/rev/6ba3bcede28a51512b8f17606b917024813e98b9
Bug 1577723: Store BrowsingContext ID in dom::Location rather than DocShell weak reference. r=farre
Flags: needinfo?(kmaglione+bmo)
https://hg.mozilla.org/integration/mozilla-inbound/rev/8bf308d3b614105afa163a31fbda128a3a20aaf3
Bug 1577723: Follow-up: Fix another crash test relied on GC timing. r=bustage

Backed out 2 changesets (Bug 1577723) for wpt failure at /html/browsers/history/the-location-interface/no-browsing-context.window.html

Push with failure: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&selectedJob=267130417&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=8bf308d3b614105afa163a31fbda128a3a20aaf3

Failure log:

  1. wpt: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=267130417&repo=mozilla-inbound&lineNumber=4300
  2. crashtests https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=267128608&repo=mozilla-inbound&lineNumber=3296

Backout link: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&selectedJob=267128608&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=375f9429ba87a12b1d7cd1497dc8fcc68e526e57

[task 2019-09-17T22:06:56.550Z] 22:06:56     INFO - TEST-FAIL | /html/browsers/history/the-location-interface/no-browsing-context.window.html | Setting `protocol` to `test` of a `Location` object sans browsing context is a no-op - The operation is insecure.
[task 2019-09-17T22:06:56.551Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:62:6
[task 2019-09-17T22:06:56.551Z] 22:06:56     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1611:25
[task 2019-09-17T22:06:56.551Z] 22:06:56     INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
[task 2019-09-17T22:06:56.551Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:60:8
[task 2019-09-17T22:06:56.551Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:59:20
[task 2019-09-17T22:06:56.551Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:58:3
[task 2019-09-17T22:06:56.551Z] 22:06:56     INFO - TEST-UNEXPECTED-FAIL | /html/browsers/history/the-location-interface/no-browsing-context.window.html | Setting `host` to `example.com` of a `Location` object sans browsing context is a no-op - The operation is insecure.
[task 2019-09-17T22:06:56.551Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:62:6
[task 2019-09-17T22:06:56.552Z] 22:06:56     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1611:25
[task 2019-09-17T22:06:56.552Z] 22:06:56     INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
[task 2019-09-17T22:06:56.552Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:60:8
[task 2019-09-17T22:06:56.552Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:59:20
[task 2019-09-17T22:06:56.552Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:58:3
[task 2019-09-17T22:06:56.553Z] 22:06:56     INFO - 
[task 2019-09-17T22:06:56.553Z] 22:06:56     INFO - TEST-UNEXPECTED-FAIL | /html/browsers/history/the-location-interface/no-browsing-context.window.html | Setting `host` to `test test` of a `Location` object sans browsing context is a no-op - The operation is insecure.
[task 2019-09-17T22:06:56.553Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:62:6
[task 2019-09-17T22:06:56.554Z] 22:06:56     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1611:25
[task 2019-09-17T22:06:56.554Z] 22:06:56     INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
[task 2019-09-17T22:06:56.554Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:60:8
[task 2019-09-17T22:06:56.554Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:59:20
[task 2019-09-17T22:06:56.554Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:58:3
[task 2019-09-17T22:06:56.555Z] 22:06:56     INFO - 
[task 2019-09-17T22:06:56.555Z] 22:06:56     INFO - TEST-UNEXPECTED-FAIL | /html/browsers/history/the-location-interface/no-browsing-context.window.html | Setting `host` to `()` of a `Location` object sans browsing context is a no-op - The operation is insecure.
[task 2019-09-17T22:06:56.555Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:62:6
[task 2019-09-17T22:06:56.555Z] 22:06:56     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1611:25
[task 2019-09-17T22:06:56.555Z] 22:06:56     INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
[task 2019-09-17T22:06:56.555Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:60:8
[task 2019-09-17T22:06:56.556Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:59:20
[task 2019-09-17T22:06:56.556Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:58:3
[task 2019-09-17T22:06:56.557Z] 22:06:56     INFO - 
[task 2019-09-17T22:06:56.557Z] 22:06:56     INFO - TEST-UNEXPECTED-FAIL | /html/browsers/history/the-location-interface/no-browsing-context.window.html | Setting `hostname` to `example.com` of a `Location` object sans browsing context is a no-op - The operation is insecure.
[task 2019-09-17T22:06:56.558Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:62:6
[task 2019-09-17T22:06:56.558Z] 22:06:56     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1611:25
[task 2019-09-17T22:06:56.558Z] 22:06:56     INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
[task 2019-09-17T22:06:56.558Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:60:8
[task 2019-09-17T22:06:56.559Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:59:20
[task 2019-09-17T22:06:56.559Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:58:3
[task 2019-09-17T22:06:56.560Z] 22:06:56     INFO - 
[task 2019-09-17T22:06:56.560Z] 22:06:56     INFO - TEST-UNEXPECTED-FAIL | /html/browsers/history/the-location-interface/no-browsing-context.window.html | Setting `port` to `80` of a `Location` object sans browsing context is a no-op - The operation is insecure.
[task 2019-09-17T22:06:56.560Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:62:6
[task 2019-09-17T22:06:56.560Z] 22:06:56     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1611:25
[task 2019-09-17T22:06:56.560Z] 22:06:56     INFO - test@http://web-platform.test:8000/resources/testharness.js:544:30
[task 2019-09-17T22:06:56.561Z] 22:06:56     INFO - @http://web-platform.test:8000/html/browsers/history/the-location-interface/no-browsing-context.window.js:6
Flags: needinfo?(kmaglione+bmo)
Flags: needinfo?(kmaglione+bmo)
https://hg.mozilla.org/integration/mozilla-inbound/rev/57d9c07bff00694f5fc7453511f024b7a3716ebb
Bug 1577723: Store BrowsingContext ID in dom::Location rather than DocShell weak reference. r=farre
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.