Closed Bug 1578271 Opened 5 months ago Closed 3 months ago

Perma browser_UsageTelemetry_reload_key_combination.js | Uncaught exception - at TelemetryTestUtils.jsm:294 - TypeError: snapshot is undefined when Gecko version increases to 72 on 2019-10-21

Categories

(Core :: Performance, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 - wontfix
firefox72 --- fixed

People

(Reporter: RaulG, Assigned: sefeng)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Version increase simulation:
https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=264557786&resultStatus=testfailed%2Cbusted%2Cexception&revision=b8832c913b1c7150d74456e803a49ebe41d376f2

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=264557786&repo=try&lineNumber=6453

Log snippet:
[task 2019-09-02T12:22:34.085Z] 12:22:34 INFO - TEST-START | browser/modules/test/browser/browser_UsageTelemetry_reload_key_combination.js
[task 2019-09-02T12:22:34.506Z] 12:22:34 INFO - TEST-INFO | started process screenshot
[task 2019-09-02T12:22:34.589Z] 12:22:34 INFO - TEST-INFO | screenshot: exit 0
[task 2019-09-02T12:22:34.589Z] 12:22:34 INFO - Buffered messages logged at 12:22:34
[task 2019-09-02T12:22:34.590Z] 12:22:34 INFO - Entering test bound setup
[task 2019-09-02T12:22:34.590Z] 12:22:34 INFO - Leaving test bound setup
[task 2019-09-02T12:22:34.590Z] 12:22:34 INFO - Entering test bound test_pageReloadOnlyF5
[task 2019-09-02T12:22:34.590Z] 12:22:34 INFO - Console message: [JavaScript Warning: "Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox”" {file: "chrome://mochikit/content/tests/SimpleTest/EventUtils.js" line: 870}]
[task 2019-09-02T12:22:34.590Z] 12:22:34 INFO - Buffered messages finished
[task 2019-09-02T12:22:34.591Z] 12:22:34 INFO - TEST-UNEXPECTED-FAIL | browser/modules/test/browser/browser_UsageTelemetry_reload_key_combination.js | Uncaught exception - at resource://testing-common/TelemetryTestUtils.jsm:294 - TypeError: snapshot is undefined
[task 2019-09-02T12:22:34.591Z] 12:22:34 INFO - Stack trace:
[task 2019-09-02T12:22:34.591Z] 12:22:34 INFO - assertHistogram@resource://testing-common/TelemetryTestUtils.jsm:294:26
[task 2019-09-02T12:22:34.592Z] 12:22:34 INFO - test_pageReloadOnlyF5/<@chrome://mochitests/content/browser/browser/modules/test/browser/browser_UsageTelemetry_reload_key_combination.js:34:24
[task 2019-09-02T12:22:34.592Z] 12:22:34 INFO - asyncwithNewTab@resource://testing-common/BrowserTestUtils.jsm:141:24
[task 2019-09-02T12:22:34.592Z] 12:22:34 INFO - async
test_pageReloadOnlyF5@chrome://mochitests/content/browser/browser/modules/test/browser/browser_UsageTelemetry_reload_key_combination.js:29:26
[task 2019-09-02T12:22:34.592Z] 12:22:34 INFO - Tester_execTest/<@chrome://mochikit/content/browser-test.js:1350:34
[task 2019-09-02T12:22:34.592Z] 12:22:34 INFO - asyncTester_execTest@chrome://mochikit/content/browser-test.js:1385:11
[task 2019-09-02T12:22:34.592Z] 12:22:34 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:1213:14
[task 2019-09-02T12:22:34.592Z] 12:22:34 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:805:67
[task 2019-09-02T12:22:34.592Z] 12:22:34 INFO - Leaving test bound test_pageReloadOnlyF5
[task 2019-09-02T12:22:34.592Z] 12:22:34 INFO - Entering test bound test_pageReloadAccelF5
[task 2019-09-02T12:22:34.917Z] 12:22:34 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-09-02T12:22:34.918Z] 12:22:34 INFO - TEST-UNEXPECTED-FAIL | browser/modules/test/browser/browser_UsageTelemetry_reload_key_combination.js | Uncaught exception - at resource://testing-common/TelemetryTestUtils.jsm:294 - TypeError: snapshot is undefined
[task 2019-09-02T12:22:34.918Z] 12:22:34 INFO - Stack trace:
[task 2019-09-02T12:22:34.918Z] 12:22:34 INFO - assertHistogram@resource://testing-common/TelemetryTestUtils.jsm:294:26
[task 2019-09-02T12:22:34.918Z] 12:22:34 INFO - test_pageReloadAccelF5/<@chrome://mochitests/content/browser/browser/modules/test/browser/browser_UsageTelemetry_reload_key_combination.js:49:26
[task 2019-09-02T12:22:34.918Z] 12:22:34 INFO - async
withNewTab@resource://testing-common/BrowserTestUtils.jsm:141:24
[task 2019-09-02T12:22:34.918Z] 12:22:34 INFO - async*test_pageReloadAccelF5@chrome://mochitests/content/browser/browser/modules/test/browser/browser_UsageTelemetry_reload_key_combination.js:44:28
[task 2019-09-02T12:22:34.918Z] 12:22:34 INFO - Tester_execTest/<@chrome://mochikit/content/browser-test.js:1350:34

Test failures because the corresponding telemetry is going to be expired in 72. I think we should remove it.
Ben, what do you think?

Flags: needinfo?(sefeng) → needinfo?(bdekoz)

Yes, remove it.

Flags: needinfo?(bdekoz)

Hey sfeng, this needs to get fixed before the merge, I'm tentatively assigning this to you for now, and marking it P1. Feel free to reassign if you're not the right person.

Assignee: nobody → sefeng
Priority: -- → P1

Aryx, the patch is accepted, can you please land it after 72 version bump? (I'll setup a reminder for myself, so I can also probably do it myself)

Flags: needinfo?(aryx.bugmail)

Sheriffs will land it directly after the version increase.

Flags: needinfo?(aryx.bugmail)
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/1ef186a26a84
Remove the expired FX_PAGE_RELOAD_KEY_COMBO probe r=Gijs,chutten a=test-fix
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Sean, am I understanding correctly that this doesn't need any uplift to 71 beta? Thanks

Flags: needinfo?(sefeng)

Pascal, that's correct. We don't need to uplift it to 71 beta.

Flags: needinfo?(sefeng)
You need to log in before you can comment on or make changes to this bug.