Check in Mac OS desktop/taskbar icons

RESOLVED DUPLICATE of bug 88393

Status

SeaMonkey
Themes
--
enhancement
RESOLVED DUPLICATE of bug 88393
16 years ago
10 years ago

People

(Reporter: Jason Kersey, Assigned: Jason Kersey)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

16 years ago
per summary.  broken off of 73712.

Comment 1

16 years ago
FWIW, Mozilla for Mac OS needs a suite of icons for the application and various
document types in various sizes (128, 48, 32, and 16 pixels square by 32, 8, 4,
and 1 bits of color deep). I'm available to help complete the production of
these icons from the finished source material.

Has anyone made an inventory of all the file types installed with Mozilla?
Blocks: 29303
Severity: normal → enhancement
Summary: Check in macintosh desktop/taskbar icons → Check in Mac OS desktop/taskbar icons
Given 128x128x32 images in any common format, it should not be too 
hard to take Gimp (or Photoshop, if someone interested has that, 
but Gimp will do just as well for this) and produce most of the 
required sizes and colour depths _mostly_ automatically with a 
few manual adjustments.  A few of the required icons, particularly
the 1-bit and 16x16 ones, may need to be mostly redrawn from scratch 
with some significant design simplifications, but this will still
be easier than creating the high-quality originals.  Another option
would be to do the images in a vector or raytracing format (such
as POV) and then render them at the various sizes, excluding some
of the detail-intensive elements for the smaller resolutions.  

Given the images at the various sizes and colour depths, it is 
trivial to do the format conversions needed for various platforms. 

Doesn't this bug depend on bug 28028, or the equivalent?

Comment 3

16 years ago
Created attachment 92519 [details]
Windows Icon with 128, 64, 48, 32, and 16 px sizes

Greg Kolanek asked me to attach this here.  I don't have a Mac so someone else
will need to convert it to the correct format.

Comment 4

16 years ago
scratch, thanks. It came through as a Windows .ico file, except there was no
128px version. If you can attach a simple PNG file with mask, I'll incorporate
it into the Mac package.

Comment 5

16 years ago
Created attachment 92532 [details]
128x128 in PNG format

Again by request from Greg Kolanek.

Comment 6

16 years ago
Created attachment 92535 [details]
MacBinary-encoded Iconographer file containing red lizard icon in Mac OS Universal (resources) format

This file contains the application icon for Mozilla for Mac OS 9 and Mac OS X
as saved by Iconographer. The same icons should be incorporated into both Mac
Mozilla variants.
Attachment #92519 - Attachment is obsolete: true
Attachment #92532 - Attachment is obsolete: true

Comment 7

16 years ago
Comment on attachment 92535 [details]
MacBinary-encoded Iconographer file containing red lizard icon in Mac OS Universal (resources) format

This needs work, in that the 1-bit variants need to be improved.
Attachment #92535 - Flags: needs-work+

Comment 8

16 years ago
I recommend the application and document icon set referred to by Terence Tan in
Bug 88393, comment 1, be used instead. That is, those at
[http://home.alphalink.com.au/~cltan/mozilla/].

Comment 9

16 years ago
Of course, reading through bug 88393 and bug 28028, I doubt any of this will
ever be allowed to occur, and for no discernable reason other than incredible
inertia.

Comment 10

16 years ago
Perhaps this bug should simply be duped to bug 88393. Kerz? What do you think?

Comment 11

15 years ago

*** This bug has been marked as a duplicate of 88393 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.