Closed Bug 1578363 Opened 1 year ago Closed 4 months ago

Add Microblaze support

Categories

(NSPR :: NSPR, enhancement)

4.23
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: giulio.benetti, Assigned: giulio.benetti)

Details

Attachments

(1 file, 2 obsolete files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36

Hello Guilio, you've filed three bugs, this one, bug 1578364 and bug 1578360.

It seems the size definitions are identical for all architectures. Are these platforms related to each other? How about combining them into a single definition block?

#elif defined(__nios2__) || defined(__nds32__) || defined(__microblaze__)

#if defined(__microblaze__) && defined(__BIG_ENDIAN__)
#define IS_BIG_ENDIAN 1
#undef  IS_LITTLE_ENDIAN
#else
#define IS_LITTLE_ENDIAN 1
#undef  IS_BIG_ENDIAN
#endif

#define PR_BYTES_PER_BYTE   1
...
#endif
Assignee: nobody → giulio.benetti
Status: UNCONFIRMED → NEW
Ever confirmed: true

(In reply to Kai Engert (:kaie:) from comment #2)

Hello Guilio, you've filed three bugs, this one, bug 1578364 and bug 1578360.

It seems the size definitions are identical for all architectures. Are these platforms related to each other? How about combining them into a single definition block?

You're totally right. I'm going to rework all 3 patches the way you've showed me below.
Thank you for reviewing,
best regards.
Giulio Benetti

#elif defined(__nios2__) || defined(__nds32__) || defined(__microblaze__)

#if defined(__microblaze__) && defined(__BIG_ENDIAN__)
#define IS_BIG_ENDIAN 1
#undef  IS_LITTLE_ENDIAN
#else
#define IS_LITTLE_ENDIAN 1
#undef  IS_BIG_ENDIAN
#endif

#define PR_BYTES_PER_BYTE   1
...
#endif
Attachment #9089997 - Attachment is obsolete: true

Kindly ping.

See Comment 5.

Flags: needinfo?(kaie)
Comment on attachment 9091877 [details] [diff] [review]
0002-Bug-1578363-Add-Microblaze-support.patch

The attached patch doesn't apply. It looks like some kind of incremental patch.
It doesn't even apply on top of the earlier patch in this bug.

Please provide a new, single patch, that includes all the pieces that you're suggesting for addition.
Flags: needinfo?(kaie)
Attachment #9091877 - Flags: review-

(In reply to Kai Engert (:kaie:) from comment #7)

Comment on attachment 9091877 [details] [diff] [review]
0002-Bug-1578363-Add-Microblaze-support.patch

The attached patch doesn't apply. It looks like some kind of incremental
patch.
It doesn't even apply on top of the earlier patch in this bug.

Please provide a new, single patch, that includes all the pieces that you're
suggesting for addition.

You're right, sorry for that, I re-post patch starting from master branch of nspr.

(In reply to Giulio Benetti from comment #8)

(In reply to Kai Engert (:kaie:) from comment #7)

Comment on attachment 9091877 [details] [diff] [review]
0002-Bug-1578363-Add-Microblaze-support.patch

The attached patch doesn't apply. It looks like some kind of incremental
patch.
It doesn't even apply on top of the earlier patch in this bug.

Please provide a new, single patch, that includes all the pieces that you're
suggesting for addition.

You're right, sorry for that, I re-post patch starting from master branch of nspr.

Now I've understood what happened. I wanted to submit 3 incremental patches with 3 different bugs.
Anyway now I attach a unique patch.

Here is cumulative patch to support:

  • Nios II
  • Nds32
  • Microblaze

Kind regards

Attachment #9091877 - Attachment is obsolete: true
Attachment #9104549 - Flags: review+
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 4.24
You need to log in before you can comment on or make changes to this bug.