Closed Bug 1578414 Opened 5 months ago Closed 4 months ago

URL autocomplete not working

Categories

(Firefox :: Address Bar, defect)

69 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1582234

People

(Reporter: jesse_a_b, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

I have these parameters in about:config

browser.urlbar.autoFill;true
browser.urlbar.oneOffSearches;true
browser.urlbar.suggest.bookmark;false
browser.urlbar.suggest.history;true
browser.urlbar.suggest.openpage;false
browser.urlbar.suggest.searches;true

The URL autocomplete doesn't complete any of the url in my history.
The only URL that ever autocomplete are URL of popular websites I never visited with the default config.
There's something seriously broken with the autocomplete in firefox, I don't have any issue with any other browser.

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Same problem here.
URL autocomplete only works for bookmarked pages, but not for open tabs and pages in the history.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Address Bar

Same problem, with the same config as jesse_a_b.

To clarify what's happening, for me at least:

  • Open a new tab, enter "n" in the url bar
  • Expectation: https://news.ycombinator.com/ will be the first suggestion, will be put in the url bar so that I can continue to type over it, and pressing enter would navigate me there, because I visit that URL often. This is how Firefox always behaved for me until a couple days ago, presumably when it upgraded itself to version 69.
  • Reality: the first suggestion is to search for "n" in google (my default search engine), and pressing enter opens this google search. The other suggestions are URLs from my browsing history which have words starting with "N" in their title, even some that don't have an "N" in their URL. https://news.ycombinator.com/ appears fifth, but seemingly only because it has "n" in the title ("Hacker News")

Also, if I type out "news.ycombinator" in the url bar, the first suggestion will be to visit this non-existent url, with the expected suggestion https://news.ycombinator.com/ being second in the list.

I have now done the following several times: enter "n" in url bar, then choose the https://news.ycombinator.com/ option. After repeating this 30+ times, https://news.ycombinator.com/ is now my second suggestion after the "n" google search, but it seems that search is mistakenly hardcoded to be the first suggestion now no matter how many times I ignore it in favor of another option.

This is very obviously broken.

I spent the last hour debugging this, it turns out the problem is this setting -

browser.urlbar.suggest.bookmark

I set this to true, and now everything works as it used to.

I checked my Firefox update history and 69.0 was installed a few days ago, so this update seems to have broken something.

For me setting browser.urlbar.suggest.bookmark to true just enabled the autocomplete drop-down and URL autocomplete for bookmarks, which works fine.
browser.urlbar.suggest.history and browser.urlbar.suggest.openpage are set to true but the URL autocomplete won't work. Autocomplete drop-down menu works though.

(In reply to jesse_a_b from comment #0)

browser.urlbar.suggest.bookmark;false

The URL autocomplete doesn't complete any of the url in my history.

I assume by "complete" you mean in the input field, not in the results panel. We name that feature autoFill.
urls are autofilled when they start with the string you are typing, and they have a sufficient score.
For example if you are typing "n" and expect https://news.ycombinator.com/ to be autofilled, that is a correct expectation, provided you visit that website often and this is not a new profile (if there's a site starting by "n" with an higher score, you may have to type "ne" or "new"...).
I tried in my profile and it works correctly, even if I disable browser.urlbar.suggest.bookmark.

Note that by bookmarking a page you can increase its score, so it's more likely to be autofilled.
Does anything change if you bookmark the page you ar eexpecting to be completed?
Could you please make an example of what you type and which url you expect to be completed?

The only URL that ever autocomplete are URL of popular websites I never visited with the default config.

What does "default config" mean here?

(In reply to Nikita from comment #3)

  • Reality: the first suggestion is to search for "n" in google (my default search engine), and pressing enter opens this google search. The other suggestions are URLs from my browsing history which have words starting with "N" in their title, even some that don't have an "N" in their URL. https://news.ycombinator.com/ appears fifth, but seemingly only because it has "n" in the title ("Hacker News")

Could you please check you didn't change the value of the browser.urlbar.autoFill pref? It should be set to true.

Also, if I type out "news.ycombinator" in the url bar, the first suggestion will be to visit this non-existent url, with the expected suggestion https://news.ycombinator.com/ being second in the list.

This is bug 1080682, unrelated.

@everyone: please attach a log from about:support page.

See Also: → 1582234

let's track this as bug 1582234.

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1582234
See Also: 1582234
You need to log in before you can comment on or make changes to this bug.