Closed Bug 1578502 Opened 3 months ago Closed 3 months ago

Can't save multiple passwords for same URL+login combination; no error shown

Categories

(Toolkit :: Password Manager, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1550122

People

(Reporter: rimas, Unassigned)

Details

in about:logins, when I try to manually create/edit an entry which duplicates (as in, has same URL and username) an existing one, this action may not be completed, yet no error is shown. The click on Save simply does nothing.

The case when such functionality might be handy is local development: you don't necessarily have all your admin passwords in sync for different projects that you work on on your machine, and you probably don't want to remember all the passwords either. Ideally, I would be able to add additional notes on such saved passwords, for easier identification, but even without them, I'd rather cycle through a couple options than have to look at all my chat logs and emails.

But even if this ability to save multiple passwords is not desired, I'd expect at least an error message to be shown for a disallowed action as opposed to nothing at all hapenning.

Are you on an updated Nightly? This was fixed a few days ago. Re-open if it happens on the latest Nightly.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1550122
You need to log in before you can comment on or make changes to this bug.