Closed Bug 1578523 Opened 2 months ago Closed 2 months ago

Delete LDAP server broken

Categories

(MailNews Core :: LDAP Integration, defect, P1)

defect

Tracking

(thunderbird70 fixed, thunderbird71 fixed)

RESOLVED FIXED
Thunderbird 71.0
Tracking Status
thunderbird70 --- fixed
thunderbird71 --- fixed

People

(Reporter: jorgk, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1576365 +++

In options, composition, addressing you bring up the list of LDAP servers and click delete.

From bug 1576365 comment #36:

Delete doesn't work at all, you get:
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIAbManager.deleteAddressBook] 2 abCommon.js:372
AbDeleteDirectory chrome://messenger/content/addressbook/abCommon.js:372
removeDirectory chrome://messenger/content/addressbook/pref-editdirectories.js:148
oncommand chrome://messenger/content/addressbook/pref-editdirectories.xul:1

Alice found this range:
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=8bbeb44f15b366817cab0573ce3807d4fc09fc33&tochange=fa465d49d7bf9f021772b7080340e9856edf71c5

Flags: needinfo?(geoff)

LDAP directories have two URIs… and I've used the wrong one.

I can't believe we have no test that fails because of this.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(geoff)
Attachment #9090247 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9090247 [details] [diff] [review]
1578523-ldap-delete-1.diff

Oh yeah, we went to beta the other day.
Attachment #9090247 - Flags: approval-comm-beta?
Comment on attachment 9090247 [details] [diff] [review]
1578523-ldap-delete-1.diff

Review of attachment 9090247 [details] [diff] [review]:
-----------------------------------------------------------------

Thx! r=mkmelin
Attachment #9090247 - Flags: review?(mkmelin+mozilla) → review+
Attachment #9090247 - Flags: approval-comm-beta? → approval-comm-beta+
Keywords: checkin-needed
Target Milestone: --- → Thunderbird 71.0
Version: 68 → 70

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/109de898dc04
Fix deletion of LDAP address book. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.