Closed Bug 1578594 Opened 1 year ago Closed 6 months ago

Perma failing [tier2 fission] devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Test timed out -

Categories

(DevTools :: Console, defect)

defect
Not set
normal

Tracking

(Fission Milestone:M4.1, firefox-esr68 disabled, firefox76 disabled, firefox77 disabled, firefox78 fixed)

RESOLVED FIXED
Firefox 78
Fission Milestone M4.1
Tracking Status
firefox-esr68 --- disabled
firefox76 --- disabled
firefox77 --- disabled
firefox78 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nchevobbe)

References

(Blocks 2 open bugs)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell disabled])

Attachments

(2 files)

Filed by: csabou [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=264831005&repo=mozilla-central
Full log: https://queue.taskcluster.net/v1/task/BIECEVudQhusKm-_UCJLrQ/runs/0/artifacts/public/logs/live_backing.log


[task 2019-09-03T23:15:12.474Z] 23:15:12 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Message includes the expected "simple message 2" content - "simple message 2 content-task.js line 62 > eval:4:21" -
[task 2019-09-03T23:15:12.475Z] 23:15:12 INFO - Reload the page and wait for it to be ready
[task 2019-09-03T23:15:12.475Z] 23:15:12 INFO - Add a storage blocked message and a content blocked one
[task 2019-09-03T23:15:12.476Z] 23:15:12 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://example.com/browser/devtools/client/webconsole/test/browser/test-image.png?7-1567552332072” was blocked because we are blocking all third-party storage access requests and content blocking is enabled." {file: "http://example.org/browser/devtools/client/webconsole/test/browser/test-warning-groups.html" line: 0}]
[task 2019-09-03T23:15:12.477Z] 23:15:12 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://example.com/browser/devtools/client/webconsole/test/browser/test-image.png?7-1567552332072” was blocked because we are blocking all third-party storage access requests and content blocking is enabled." {file: "http://example.org/browser/devtools/client/webconsole/test/browser/test-warning-groups.html" line: 0}]
[task 2019-09-03T23:15:12.477Z] 23:15:12 INFO - Buffered messages logged at 23:13:42
[task 2019-09-03T23:15:12.478Z] 23:15:12 INFO - Longer timeout required, waiting longer... Remaining timeouts: 1
[task 2019-09-03T23:15:12.478Z] 23:15:12 INFO - Buffered messages finished
[task 2019-09-03T23:15:12.480Z] 23:15:12 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Test timed out -
[task 2019-09-03T23:15:14.770Z] 23:15:14 INFO - Removing tab.
[task 2019-09-03T23:15:14.771Z] 23:15:14 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-09-03T23:15:14.794Z] 23:15:14 INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-09-03T23:15:14.825Z] 23:15:14 INFO - Tab removed and finished closing
[task 2019-09-03T23:15:15.055Z] 23:15:15 INFO - GECKO(1145) | JavaScript error: resource://testing-common/PromiseTestUtils.jsm, line 112: uncaught exception: Object
[task 2019-09-03T23:15:15.056Z] 23:15:15 INFO - Console message: [JavaScript Error: "uncaught exception: Object" {file: "resource://testing-common/PromiseTestUtils.jsm" line: 112}]
[task 2019-09-03T23:15:15.058Z] 23:15:15 INFO - TEST-FAIL | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Assertion count 2 is greater than expected range 0-0 assertions. -

Summary: Perma fission devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Test timed out - → Intermittent fission devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Test timed out -

Tentatively moving all bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to the "?" triage milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → ?
Fission Milestone: ? → M4.1

:nchevobbe - this test has been permafailing on linux1804-64/opt fission and linux1804-64/debug fission.

My understanding is that the fission variant of devtools-chrome is only run on linux64/opt and linux64/debug for mozilla-central. As the linux1804-64 task will be replacing the existing linux64 tasks, resolving this permafail is high on my list of thing to do prior to the all hands.

Could you take a look, or redirect the ni to someone that can advise? Alternatively, would temporarily marking this as a permafail on linux1804 && fission a good way forward?

try push: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&tier=1%2C2%2C3&searchStr=devtools%2C&revision=16cb55301f7f5522ce616b896843c0a07f31b2e4

To run a push using the ubuntu1804 test image on try, please use ./mach try fuzzy --ubuntu-bionic and select linux64 jobs as normal, since the task has not been enabled for linux1804 yet.

Set ni.

Flags: needinfo?(nchevobbe)

I set up a ubuntu 18.04 vm and tried to run the test with fission, without success for now.
Since all hands is starting Monday, I suggest to disable this test for fission, and I'll go back to it when I have a bit more time (or when we decide to spend time enabling devtools tests for fission).

Flags: needinfo?(nchevobbe)

Thanks. Currently devtools-chrome is running on mozilla-central on linux1804, and the test fails with high frequency but is not a permafail, it seems.

This seems to have been fixed at the end of January https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2020-01-16&endday=2020-02-15&tree=trunk&bug=1578594 but started again on the 13th of February.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=289059400&repo=mozilla-central&lineNumber=12288

[task 2020-02-15T11:00:56.431Z] 11:00:56 INFO - TEST-START | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js
[task 2020-02-15T11:00:57.747Z] 11:00:57 INFO - GECKO(10851) | console.log: "simple message 1"
[task 2020-02-15T11:02:26.446Z] 11:02:26 INFO - TEST-INFO | started process screentopng
[task 2020-02-15T11:02:26.689Z] 11:02:26 INFO - TEST-INFO | screentopng: exit 0
[task 2020-02-15T11:02:26.689Z] 11:02:26 INFO - Buffered messages logged at 11:00:56
[task 2020-02-15T11:02:26.689Z] 11:02:26 INFO - Entering test bound testContentBlockingMessage
[task 2020-02-15T11:02:26.689Z] 11:02:26 INFO - Adding a new tab with URL: http://example.org/browser/devtools/client/webconsole/test/browser/test-warning-groups.html
[task 2020-02-15T11:02:26.689Z] 11:02:26 INFO - Buffered messages logged at 11:00:57
[task 2020-02-15T11:02:26.689Z] 11:02:26 INFO - Tab added and finished loading
[task 2020-02-15T11:02:26.689Z] 11:02:26 INFO - Opening the toolbox
[task 2020-02-15T11:02:26.689Z] 11:02:26 INFO - Console message: [JavaScript Error: "Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”)." {file: "chrome://global/content/elements/panel.js" line: 62}]
[task 2020-02-15T11:02:26.689Z] 11:02:26 INFO - Console message: [JavaScript Error: "Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”)." {file: "chrome://global/content/elements/panel.js" line: 62}]
[task 2020-02-15T11:02:26.703Z] 11:02:26 INFO - Toolbox opened and focused
[task 2020-02-15T11:02:26.704Z] 11:02:26 INFO - Log a tracking protection message to check a single message isn't grouped
[task 2020-02-15T11:02:26.705Z] 11:02:26 INFO - Console message: [JavaScript Warning: "The resource at “http://tracking.example.com/browser/devtools/client/webconsole/test/browser/test-image.png?1-1581764456435” was blocked because content blocking is enabled." {file: "http://example.org/browser/devtools/client/webconsole/test/browser/test-warning-groups.html" line: 0}]
[task 2020-02-15T11:02:26.705Z] 11:02:26 INFO - Matched a message with text: "http://tracking.example.com/browser/devtools/client/webconsole/test/browser/test-image.png", all messages received.
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | The message has the expected style -
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | The message has the expected indent -
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - Log a simple message
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - Matched a message with text: "simple message 1", all messages received.
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - Log a second tracking protection message to check that it causes the grouping
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - Console message: [JavaScript Warning: "The resource at “http://tracking.example.com/browser/devtools/client/webconsole/test/browser/test-image.png?2-1581764456435” was blocked because content blocking is enabled." {file: "http://example.org/browser/devtools/client/webconsole/test/browser/test-warning-groups.html" line: 0}]
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - Matched a message with text: "The resource at “<URL>” was blocked because content blocking is enabled.", all messages received.
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | The badge has the expected text -
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Got the expected number of messages -
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - Checking "▶︎⚠ The resource at “<URL>” was blocked because content blocking is enabled."
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | There's a collapsed arrow -
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | The warningGroup has the expected indent -
[task 2020-02-15T11:02:26.706Z] 11:02:26 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | The message has the expected indent -
[task 2020-02-15T11:02:26.707Z] 11:02:26 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Message includes the expected "The resource at “<URL>” was blocked because content blocking is enabled." content - "The resource at “<URL>” was blocked because content blocking is enabled. 2" -
[task 2020-02-15T11:02:26.707Z] 11:02:26 INFO - Checking "simple message 1"
[task 2020-02-15T11:02:26.707Z] 11:02:26 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | The message has the expected indent -
[task 2020-02-15T11:02:26.707Z] 11:02:26 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Message includes the expected "simple message 1" content - "simple message 1 browser_webconsole_warning_group_multiples.js:303:21" -
[task 2020-02-15T11:02:26.709Z] 11:02:26 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://example.com/browser/devtools/client/webconsole/test/browser/test-image.png?3-1581764456435” was blocked because we are blocking all third-party storage access requests and content blocking is enabled."]
[task 2020-02-15T11:02:26.714Z] 11:02:26 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://example.com/browser/devtools/client/webconsole/test/browser/test-image.png?3-1581764456435” was blocked because we are blocking all third-party storage access requests and content blocking is enabled."]
[task 2020-02-15T11:02:26.715Z] 11:02:26 INFO - Buffered messages logged at 11:01:41
[task 2020-02-15T11:02:26.716Z] 11:02:26 INFO - Longer timeout required, waiting longer... Remaining timeouts: 1
[task 2020-02-15T11:02:26.717Z] 11:02:26 INFO - Buffered messages finished
[task 2020-02-15T11:02:26.717Z] 11:02:26 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Test timed out -
[task 2020-02-15T11:02:26.718Z] 11:02:26 INFO - Removing tab.
[task 2020-02-15T11:02:26.720Z] 11:02:26 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2020-02-15T11:02:26.720Z] 11:02:26 INFO - Got event: 'TabClose' on [object XULElement].
[task 2020-02-15T11:02:26.721Z] 11:02:26 INFO - GECKO(10851) | console.warn: "IGNORED REDUX ACTION:" ({type:"AUTOCOMPLETE_CLEAR"})
[task 2020-02-15T11:02:26.721Z] 11:02:26 INFO - Tab removed and finished closing
[task 2020-02-15T11:02:26.721Z] 11:02:26 INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | The main process DebuggerServer has no pending connection when the test ends -
[task 2020-02-15T11:02:26.798Z] 11:02:26 INFO - GECKO(10851) | MEMORY STAT | vsize 4050MB | residentFast 528MB | heapAllocated 160MB
[task 2020-02-15T11:02:26.798Z] 11:02:26 INFO - TEST-OK | devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | took 90371ms

This is perma-failing only on mozilla-central on linux1804-64 opt and debug and windows10-64 opt starting with this merge https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=b47e32ff95b8d544ea1e94374e1d5ad8929bba39

Summary: Intermittent fission devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Test timed out - → Perma failing [tier2 fission] devtools/client/webconsole/test/browser/browser_webconsole_warning_group_multiples.js | Test timed out -

Did this start when bug 1613035 landed?

Flags: needinfo?(nchevobbe)

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #32)

Did this start when bug 1613035 landed?

It shouldn't, as the test wasn't modified (nor the annotation) in this bug.
There's definitely issue with Fission and tracking protection messages which I did not get the time to investigate properly yet.
Let me check if I can reproduce the failing on my ubuntu 18.04 VM.

Flags: needinfo?(nchevobbe)
Whiteboard: [stockwell needswork:owner]

This bug failed 70 times in the last 7 days. Occurs on linux1804-64 and windows10-64 platforms on opt and debug build types.

Recent log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=290219905&repo=mozilla-central&lineNumber=12319

I'll try to reproduce again as it looks like it's more frequent now (last time I tried, I had no luck reproducing it :/ )

(In reply to Nicolas Chevobbe [:nchevobbe] from comment #38)

I'll try to reproduce again as it looks like it's more frequent now (last time I tried, I had no luck reproducing it :/ )

This runs only on mozilla-central, could it be because of that?

Flags: needinfo?(nchevobbe)
Assignee: nobody → btara
Status: NEW → ASSIGNED
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled(fission)]
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2cd147700378
Skip browser_webconsole_warning_group_multiples.js on fission since it's perma failing r=nchevobbe,jmaher
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]

(clearing ni)

Flags: needinfo?(nchevobbe)

Nicolas, will you be able to look at this Fission test bug soon? Fixing and re-enabling mochitests blocks enabling Fission in Nightly.

This test is still disabled for Fission:

https://searchfox.org/mozilla-central/rev/4166c15e2a99a23a9b38ad62c9fdfe8e5448b354/devtools/client/webconsole/test/browser/_webconsole.ini#376-377

Assignee: btara → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(nchevobbe)
Priority: P5 → --

The Fission team hopes to roll out Fission to some Nightly users in Q3, so it would be good if all tests are passing and enabled for Fission by the end of Q2.

The test seems to run fine on fission, so let's run it.

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/66087bb120a4
Unskip browser_webconsole_warning_group_multiples.js on fission. r=ladybenko.
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
You need to log in before you can comment on or make changes to this bug.