Closed Bug 1578628 Opened 1 year ago Closed 1 year ago

fission: "name" attribute on cross-origin frames

Categories

(Core :: DOM: Core & HTML, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Fission Milestone M4
Tracking Status
firefox71 --- fixed

People

(Reporter: pbone, Assigned: pbone)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

js/xpconnect/tests/mochitest/test_bug916945.html is failing because the "name" attribute doesn't work on cross-origin frames.

Fission Milestone: ? → M4

Depends on D44945

Pushed by pbone@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b668ff9bcb38
Enable disabled test points r=bholley,kmag
https://hg.mozilla.org/integration/autoland/rev/43eace6b88a7
Fix a spelling mistake in a comment r=kmag
https://hg.mozilla.org/integration/autoland/rev/3b9e96b71449
Set the name on the BrowsingContext not the nsDocShell r=kmag
Regressions: 1612431
You need to log in before you can comment on or make changes to this bug.