Closed Bug 1578754 Opened 2 years ago Closed 2 years ago

Implement groups for messaging system

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 73
Iteration:
71.2 - Sept 16 - 29
Tracking Status
firefox70 --- unaffected
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- verified

People

(Reporter: k88hudson, Assigned: andreio)

References

(Blocks 1 open bug)

Details

User Story

Technical doc: https://docs.google.com/document/d/1XyHQrvneQjJvQW2Q4KnMR8JPUc8surjhpNQxl0ss5xY/edit#heading=h.e1gc7715wbcj

Attachments

(2 files)

Based on our discussion, we are considering adding the concept of groups to messages within Messaging System, to help with the following:

  • mapping prefs to certain messages
  • detaching the concept of a RS bucket
  • inter-provider frequency capping
  • telemetry rules
  • blocking multiple messages
See Also: → 1578771
Assignee: nobody → andrei.br92
Iteration: --- → 71.1 - Sept 2 - 15
Priority: -- → P1
Blocks: 1578771
Iteration: 71.1 - Sept 2 - 15 → 71.2 - Sept 16 - 29
Depends on: 1573933
User Story: (updated)
Summary: Consider implementing "groups" for messages → Implement groups for messaging system
Blocks: x-man
Attachment #9114882 - Attachment description: Bug 1578754 - Consider implementing groups for messages → Bug 1578754 - Implement groups configuration for Messaging System content
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8e314364e610
Implement groups configuration for Messaging System content r=k88hudson
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

I have verified that the "browser.newtabpage.activity-stream.asrouter.devtoolsEnabled" section containing the "Message Groups" is successfully displayed in the "AS Router Admin" page. Verified with the latest Firefox Nightly (73.0a1 Build ID - 20200106092427) installed on Windows 10 x64, Mac 10.15.2, and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Regressions: 1610298
See Also: → 1643404
You need to log in before you can comment on or make changes to this bug.