Closed Bug 1578831 Opened 1 year ago Closed 1 year ago

Privacy Panel: Send report string on OFF state

Categories

(Firefox :: Protections UI, task, P3)

task

Tracking

()

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: betsymi, Assigned: nhnt11)

References

Details

(Whiteboard: [privacy-panel][skyline])

Attachments

(3 files)

Problem: If user turns off ETP, it's not helpful if they report the site is still broken. This would mean ETP was not the cause of the breakage and a report will not be useful. Firefox would like to know about sites in which turning off ETP led to fixing breakage.

Resolution: Ask users to report if turning off ETP fixed breakage.

Attached is comp for prompting users to send report upon fixage. Please note, the string is outdated on the comp and it is for visual reference only.

  • String: Is this website working properly now? Send report
  • Appears in OFF state only
  • Link Send Report directly to Report a Broken Site subpanel
Attached image Send Report.png

I'm going to work on this shortly and had one important question:

Is this replacing the "Site Not Working?" link when ETP is ON? Or is it an additional link when ETP is OFF? And if it's an addition, should we remove the Send Report link from the "Site Not Working?" subview?

It's a bit urgent to spec this out properly because it's a string change/addition and uplift should happen ASAP. :flod, could you help me figure out if this is a reasonable string addition to uplift? I can't remember the last time I uplifted strings (maybe for a cert error string at some point).

Flags: needinfo?(epang)
Flags: needinfo?(chsiang)
Flags: needinfo?(bmikel)

Forgot to needinfo? flod in comment 3.

Flags: needinfo?(francesco.lodolo)

(In reply to Nihanth Subramanya [:nhnt11] from comment #3)

I'm going to work on this shortly and had one important question:
Is this replacing the "Site Not Working?" link when ETP is ON?

No, the link and string stays as in when ETP is on

Or is it an additional link when ETP is OFF? And if it's an addition, should we remove the Send Report link from the "Site Not Working?" subview?

No need, the link should go directly to the 'Report a Broken Site' panel and bypass the panel with the 'Send Report' link

Flags: needinfo?(epang)
Flags: needinfo?(chsiang)
Flags: needinfo?(bmikel)

It's a bit urgent to spec this out properly because it's a string change/addition and uplift should happen ASAP. :flod, could you help me figure out if this is a reasonable string addition to uplift? I can't remember the last time I uplifted strings (maybe for a cert error string at some point).

Given that we don't have a patch yet, I would expect to need a few more days before strings are actually available for localization.

That's a risk that product needs to evaluate: how important is this feature in 70? It's important enough to accept that some languages might end up with partially localized panels? Note that some will do anyway, given that there's no commitment to ship 100% localization outside of French and German.

Flags: needinfo?(francesco.lodolo)

I don't think this is something that needs to go into 70 personally, 71 is fine for this. Let's not stress the process more than necessary.

Priority: P1 → P3

Yes, 71 is fine. Thank you.

Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Attachment #9097287 - Attachment description: Bug 1578831 - Link directly to breakage report subview when ETP is off. r=johannh → Bug 1578831 - Link directly to breakage report subview when ETP is off. r=timhuang
Attachment #9097287 - Attachment description: Bug 1578831 - Link directly to breakage report subview when ETP is off. r=timhuang → Bug 1578831 - Link directly to breakage report subview when ETP is off. r=timhuang!
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8c3fd95b4e26
Link directly to breakage report subview when ETP is off. r=timhuang,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
Regressions: 1594976
You need to log in before you can comment on or make changes to this bug.