Closed Bug 1578947 Opened 3 months ago Closed 2 months ago

Add the ability to know when content is first painted (First Contentful Paint event)

Categories

(GeckoView :: General, enhancement, P2)

Unspecified
All
enhancement

Tracking

(firefox70 wontfix, firefox71 fixed)

RESOLVED FIXED
mozilla71
Tracking Status
firefox70 --- wontfix
firefox71 --- fixed

People

(Reporter: rbarker, Assigned: rbarker)

References

Details

Attachments

(1 file)

In FxR the surface is first cleared with a transparent color. This means that waiting for the first paint callback doesn't actually indicate when content has been painted an windows are transparent when first shown until content is actually painted. Adding the ability to know when content has been painted would allow us to delay showing the window and associated UI until there is something to display.

James suggests listening for First Contentful Paint event. This should help remove white flashes on page loads.

Assignee: nobody → rbarker
Priority: -- → P2
Summary: Add the ability to know when content is first painted. → Add the ability to know when content is first painted (First Contentful Paint event)
Whiteboard: [geckoview:fxr:p2]
See Also: → 1578949
Rank: 12
Whiteboard: [geckoview:fxr:p2]
Duplicate of this bug: 1578949
Pushed by jwillcox@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/16f534a22bc6
Add onFirstContentfulPaint() to GeckoView#ContentDelegate r=geckoview-reviewers,smaug,agi,snorp

That has nothing to do with my patch. But phabricator seems to be having issues. It was nearly impossible to even get my patch queue.

Flags: needinfo?(rbarker)
Pushed by rbarker@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e979b0b05541
Add onFirstContentfulPaint() to GeckoView#ContentDelegate r=geckoview-reviewers,smaug,agi,snorp
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

firefox70=wontfix because we don't need to uplift to GV 70 Beta. FxR needs this onFirstContentfulPaint patch, but FxR has it now because FxR still uses GV Nightly.

You need to log in before you can comment on or make changes to this bug.