Closed Bug 1579048 Opened 1 year ago Closed 1 year ago

[10.15] Crash report is not generated in about:crashes (on stronghold.co)

Categories

(Toolkit :: Crash Reporting, defect)

defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox71 --- affected

People

(Reporter: simona.marcu, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0
Build ID: 20190904163258
macOS Catalina - version 10.15 Beta 7 (19A546d)

Steps to reproduce:

  1. Launch Nightly 71.0a1
  2. Go to https://stronghold.co/careers/

Actual results:
The tab crashes, the crash dialog appears incomplete and the report is not submitted at all in about:crashes.

Expected results:
The website is properly loaded and If any crash should occur, then the crash dialog is properly displayed, the crash report is submitted accordingly and can be seen in about:crashes.

Please note that if the crash is generated via about:crashparent or via about:crashcontent - then the crash dialog is properly displayed and the report can be seen after submission in about:crashes.
This issue not reproducible on Firefox 69 or on Firefox 70 beta 3.
This issue is not reproducible on Mac OS X 10.14.

Summary: [10.15] Crash report is not generated in about:crashes → [10.15] Crash report is not generated in about:crashes (on Stronghold.com)

Wondering if this belongs in Toolkit | Crash Reporting instead of Widget | Cocoa. Adding a ni on Gabriele.

Flags: needinfo?(gsvelto)

Definitely crash reporting. I'll have a look tomorrow.

Component: Widget: Cocoa → Crash Reporting
Flags: needinfo?(gsvelto)
Product: Core → Toolkit

I couldn't reproduce on Mojave, I'm installing the Catalina Beta update to see if I can reproduce the crash with that combination.

I could reproduce on Catalina. So the crash is Catalina-specific and might not be caused by Firefox. The lack of a crash report however is most likely our fault. Catalina is removing support for 32-bit applications and our exception handler still relies on 32-bit functionality in the kernel. I'll try with the fix for bug 1035892 applied and see if the issue goes away.

Summary: [10.15] Crash report is not generated in about:crashes (on Stronghold.com) → [10.15] Crash report is not generated in about:crashes (on stronghold.co)

I did some further tests and the problem seems to be gone. The crash was most likely happening outside of our code and it's possible that the latest beta update to macOS Catalina fixed it. I'm closing this as it's not reproducing anymore.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.