Closed Bug 1579062 Opened 1 year ago Closed 1 year ago

Perma <random>interpolation.html | padding interpolation - NotSupportedError: Animation to or from an underlying value is not yet supported. when Gecko 71 merges to Beta on 2019-10-14

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- verified

People

(Reporter: ccoroiu, Assigned: daisuke)

Details

(Keywords: regression)

Attachments

(5 files)

[Tracking Requested - why for this release]:

Central as beta:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=c3e783a4e7b856e063c52412ff3e25b2f175f8c5&selectedJob=265124259

Failure logs:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=265124259&repo=try&lineNumber=1977
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=265132081&repo=try&lineNumber=2576
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=265132079&repo=try&lineNumber=2560
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=265121463&repo=try&lineNumber=2417
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=265121447&repo=try&lineNumber=3336

Failures:
TEST-UNEXPECTED-FAIL | /css/css-box/animation/padding-interpolation.html | padding interpolation - NotSupportedError: Animation to or from an underlying value is not yet supported.
TEST-UNEXPECTED-ERROR | /css/css-backgrounds/animations/border-color-interpolation.html | NotSupportedError: Animation to or from an underlying value is not yet supported.
TEST-UNEXPECTED-FAIL | /css/css-transforms/animation/transform-interpolation-006.html | transform interpolation - NotSupportedError: Animation to or from an underlying value is not yet supported.
TEST-UNEXPECTED-FAIL | /css/css-multicol/animation/column-count-interpolation.html | column-count interpolation - NotSupportedError: Animation to or from an underlying value is not yet supported.
TEST-UNEXPECTED-FAIL | /css/css-transforms/animation/transform-interpolation-006.html | transform interpolation - NotSupportedError: Animation to or from an underlying value is not yet supported.

Flags: needinfo?(daisuke)
Flags: needinfo?(daisuke)
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cc83d7fe35d8
Turn on dom.animations-api.implicit-keyframes.enabled for css-box tests. r=birtles
https://hg.mozilla.org/integration/autoland/rev/58011a2d3dbc
Turn on dom.animations-api.implicit-keyframes.enabled for css-backgrounds tests. r=birtles
https://hg.mozilla.org/integration/autoland/rev/2d92a2fa764a
Turn on dom.animations-api.implicit-keyframes.enabled for css-transforms tests. r=birtles
https://hg.mozilla.org/integration/autoland/rev/62f5b57b9a03
Turn on dom.animations-api.implicit-keyframes.enabled for css-multicol tests. r=birtles

James, can we set a pref to be true for all WPT runs?

The issue is Blink checked in a common interpolation test function that uses a feature we have prefed-off on beta/release. That test function gets used by dozens of specs and every time someone uses it in a new spec we need to add another __dir__.ini to un-break beta.

I notice there is a root __dir__.ini but I don't see any prefs set in it, so I guess it's not the done thing?

Flags: needinfo?(james)

This pref is required by the common animation interpolation test function used
in many of the CSS test suites but currently we only enable it on Nightly. As a
result, each time a new spec adds animation tests, we get failures on our beta
simulations. Rather than turn this on for each directory it is used in each
time a new failure occurs, this patch makes us set it globally.

This patch also removes a number of instances where we set this pref locally.
It only removes the instances that were specifically added due to the
introduction of the common CSS interpolation test function. The existing
instances remain untouched since they serve as documentation of other places
where we are specifically testing that feature.

Flags: needinfo?(brian)
Pushed by bbirtles.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/288f3414b425
Set dom.animations-api.implicit-keyframes.enabled to true for all WPT; r=daisuke

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
You need to log in before you can comment on or make changes to this bug.