Closed Bug 1579105 Opened 7 months ago Closed 7 months ago

build fails with --disable-dbus due to third_party/rust/audio_thread_priority

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1561207

People

(Reporter: adam, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

Build firefox from hg 7f404d9a40c6b6312fe2f890844bace02c301d61 using --disable-dbus in .mozconfig

Actual results:

Build failed. The third_party/rust/audio_thread_priority crate has a hard dependency on dbus, so it links to libdbus.so whether you ask for it or not. Then when libgkrust.a is linked without -ldbus it has missing symbols.

I clobbered in a fix by simply eviscerating third_party/rust/audio_thread_priority. My low-priority audio is still groovy.

Expected results:

Build should have succeeded without a dbus dependency.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → General
Product: Firefox → Firefox Build System
Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1561207
You need to log in before you can comment on or make changes to this bug.