Closed Bug 1579157 Opened 1 year ago Closed 1 year ago

Cranelift: proper support of dynamic heaps

Categories

(Core :: Javascript: WebAssembly, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: bbouvier, Assigned: bbouvier)

References

Details

Attachments

(1 file)

Cranelift tests are failing with --wasm-disable-huge-memory.

One issue I've seen is a very recent regression in Cranelift, that has not landed yet in Spidermonkey.

One other issue involves growing the heap, since there's an explicit comment in the code that the heap base is supposed to fixed: the wasm/resizing.js test is failing on inbound, probably because of this.

Priority: -- → P2
Attachment #9091036 - Attachment description: Bug 1579157: Cranelift: mark Heap as read-only only in the huge memory case; r?rhunt → Bug 1579157: Cranelift: mark Heap as read-only only in the huge memory case; r=rhunt
Pushed by bbouvier@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c1fc5c5e39c0
Cranelift: mark Heap as read-only only in the huge memory case; r=rhunt
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Assignee: nobody → bbouvier
You need to log in before you can comment on or make changes to this bug.