Closed Bug 1579631 Opened 2 years ago Closed 2 years ago

No scrollbar arrows in Developer Tools on Linux

Categories

(DevTools :: General, defect)

69 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1504787

People

(Reporter: gwarser, Assigned: emilio)

Details

Attachments

(3 files, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

I want to easily scroll through source code when viewing in Developer Tools, so I put this in ~/.config/gtk-3.0/gtk.css to force scrollbar arrows in my GTK3 theme:

.scrollbar, scrollbar, *{
-GtkScrollbar-has-backward-stepper: 1;
-GtkScrollbar-has-forward-stepper: 1;
-GtkRange-slider-width: 13;
-GtkRange-stepper-size: 13;
}

Actual results:

  • scrollbar arrows are present in main Firefox window
  • no scrollbar arrows in Developer Tools and Browser Console
  • in sources with lot of lines or with very long lines dragging scrollbar by mouse moves content not consistently which causes loss of current reading context

Expected results:

I want to have scrollbar arrows to easily/precisely navigate in code with many and very long lines.

Currently for horizontal scrolling best I can achieve is to:

  • scroll by full "viewport" width when clicking on scrollbar background - this way is not easy to keep context; OR
  • use text cursor and keyboard arrows which is slow to start and to change scrolling direction

Vertical scrolling is easier only because I have mouse with scroll wheel.

Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0 on Manjaro KDE

Attached image Breath theme.png

And one more related issue: my default GTK3 theme on Manjaro is Adwaita (image in bug description). When I change it to Breath, scrollbars start to be unusable - see attached image - small squares on the ends of scrollbars is not arrow but actual scrollbar handle. It have identical color to background and starts to be invisible when scrolled few (~10) lines.

Attached image scroll back.png

After scrolling few screen widths in long texts, there is no way to get back by small step - I will need to click on this 1-2px wide bar of scrollbar background between scrollbar handle and editor frame.

From :fvsch

We don't use GTK scrollbars on Linux at all. As soon as you use scrollbar-color in CSS, Firefox falls back to a simple scrollbar design that doesn't use the GTK widgets
See https://bugzilla.mozilla.org/show_bug.cgi?id=1504787 for more context, and that bug might be duped to it I believe

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1504787

They look ok as-is, but make it an opt-in for now.

Assignee: nobody → emilio

Comment on attachment 9201189 [details]
Bug 1579631 - Allow users to opt-in into scrollbar-buttons on GTK. r=mstange,spohl

Revision D104074 was moved to bug 1690812. Setting attachment 9201189 [details] to obsolete.

Attachment #9201189 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.