Closed Bug 1579834 Opened 4 months ago Closed 4 months ago

[Webrtc] Add mips64el build support

Categories

(Core :: WebRTC, defect, P5)

71 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: wangqing-hf, Assigned: mutao-hf)

Details

Attachments

(3 files, 2 obsolete files)

Attached file build-mips64el.log

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3189.0 Safari/537.36

Steps to reproduce:

  1. get inbound code
  2. ./mach configure
  3. ./mach build

Actual results:

/home/loongson/gecko-dev/media/webrtc/trunk/webrtc/api/audio_codecs/isac/audio_decoder_isac.h:19:2: error: "Must choose either fix or float"
#error "Must choose either fix or float"

Expected results:

build success

I have a patch needed to review, thanks!!!

Sorry, this patch is ok!

Attachment #9091414 - Attachment is obsolete: true
Attachment #9091667 - Attachment description: Bug 1579834 - [WebRTC] Add mips64 support with defined WEBRTC_CODEC_ISAC → Bug 1579834 - [WebRTC] Add mips64 support with defined WEBRTC_CODEC_ISAC; r=TomGrab
Attachment #9091667 - Attachment description: Bug 1579834 - [WebRTC] Add mips64 support with defined WEBRTC_CODEC_ISAC; r=TomGrab → Bug 1579834 - [WebRTC] Add mips64 support with defined WEBRTC_CODEC_ISAC; r=dminor
Attachment #9091667 - Attachment description: Bug 1579834 - [WebRTC] Add mips64 support with defined WEBRTC_CODEC_ISAC; r=dminor → Bug 1579834 - [WebRTC] Add mips64 support with defined WEBRTC_CODEC_ISAC
Attachment #9091667 - Attachment description: Bug 1579834 - [WebRTC] Add mips64 support with defined WEBRTC_CODEC_ISAC → Bug 1579834 - [WebRTC] Add mips64 support with defined WEBRTC_CODEC_ISAC; r=dminor
Attachment #9091667 - Attachment is obsolete: true
Component: Untriaged → WebRTC
Product: Firefox → Core
Assignee: nobody → mutao-hf
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5

Hey Chris, I think there might be something strange with the moz.build code generation with the json files attached to this bug. On my x86_64 Linux system, I end up with sandbox validation errors due to files being added to UNIFIED_SOURCES twice. The first instance is:

Source file should only be added to UNIFIED_SOURCES once: /media/webrtc/trunk/webrtc/common_audio/signal_processing/complex_bit_reverse.c

Looking at media/webrtc/trunk/webrtc/common_audio/common_audio_c_gn/moz.build, the generated file is adding it for:

if CONFIG["MOZ_DEBUG"] == "1":
...

and then again for:

if CONFIG["CPU_ARCH"] == "x86_64" and CONFIG["OS_TARGET"] == "Linux":
...

If I fix that instance of the problem I hit something similar with media/webrtc/trunk/webrtc/modules/audio_coding/isac_fix_c_gn/moz.build and media/webrtc/trunk/webrtc/modules/audio_processing/audio_processing_c_gn/moz.build, and maybe more, that was the point where I gave up.

I was wondering if you could have a look?

Flags: needinfo?(cmanchester)

Of course. The issue appears to be "MOZ_DEBUG": 1, (1 as an int, not a string as in the others) in the mips64_True_mips64_linux.json file. If I change that to be a string things seem to be generated correctly.

Sorry this is so brittle, I briefly looked into how to make this raise a useful error in cases like these but it seems a little awkward. Please file another bug if you'd like me to look into that at some point. Thanks!

Flags: needinfo?(cmanchester)

@Chris Thanks for your advice!!!

That fixed my local build. I've started a try job here: https://treeherder.mozilla.org/#/jobs?repo=try&revision=95b5085b651f26a77a9d568b24f29faf13401b47. As long as that looks good, this should be fine to land. Thanks for your patience.

Would you like me to land this for you or are you waiting on the additional reviewers?

Flags: needinfo?(mutao-hf)
Flags: needinfo?(mutao-hf)
Keywords: checkin-needed
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.