Closed Bug 1580115 Opened 3 months ago Closed 3 months ago

[FxA] The avatar icon has a square shape in the reconnect state

Categories

(Firefox :: Firefox Accounts, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 --- verified
firefox71 --- verified

People

(Reporter: Ovidiu, Assigned: vbudhram)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxa] [skyline])

Attachments

(4 files)

Affected versions

  • Tested on FF Nightly 71.0a1(2019-09-09) and FF Beta 70.0b4

Affected platforms

  • Tested on Mac Os X 10.14, Windows 10, Ubuntu 18.04

Steps to reproduce

Prerequisites: You need to be connected on 2 profiles with the same sync account.(don't close the profiles)

Steps:

  1. In profile 1 click on the FxA avatar icon and go to Manage Account
  2. Find the word Password and click on "Change"
  3. Change your password.
  4. Go to profile 2 and click on the FxA avatar toolbar icon.

Expected result

  • The avatar icon has a round shape and you are informed that you need to reconnect with sync.

Actual result

  • The avatar icon has a square shape and you are informed that you need to reconnect with sync.

Please see the attached print-screen for a better understanding.

Assignee: nobody → vbudhram
Whiteboard: [fxa]
Pushed by vbudhram@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0c2c86f22204
Fix fxa menu disconnected avatar r=eoger,markh
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

I tested this issue on Mac OS X 10.14 and Windows 10 with FF Nightly 71.0a1(2019-09-25) and I think there is a regression, I followed the steps from the description but I don't see the message where you are informed that you need to reconnect. (the yellow triangle).

Vijay, can you please take a look at this and let me know what is your opinion? Thanks

Flags: needinfo?(vbudhram)
Whiteboard: [fxa] → [fxa] [skyline]
Attached image reconnectosync.png

Hey :ovidiu,

I believe the reconnect state (yellow triangle) takes several minutes to get reflected in the browser. After changing passwords, I was able to get this state from closing the browser and opening it again. Can you give that a try?

Note that it no longer shows the users avatar but the unverified avatar icon.

Flags: needinfo?(vbudhram) → needinfo?(ovidiu.boca)

Hi,
I retested it on Mac OS X 10.14 and I waited approx 10 minutes and I didn't saw the yellow triangle, after the restart the warning was there.
I don't know if this behavior is intended or not but from the user point of view I don't think this is intuitive. The idea of the yellow triangle that is considered an alert, is to offer some info about some changes or some actions that are needed from the user.
I think the functionality of this should be similar to the one before the fix, the alert should be displayed instantly after the password was changed.
Lat's take, for example, the situation when the user needs to confirm the email address, also in this case an alert is displayed, but here the alert is displayed instantly. So these scenarios(confirm and update) are very similar and should have the same alert behavior, instantly. (no restart/wait minutes).
Please let me know what is your opinion about the things mentioned above.

Flags: needinfo?(ovidiu.boca)
Depends on: 1585299
No longer depends on: 1585299

Does this need a Beta uplift request?

Flags: needinfo?(vbudhram)

Beta/Release Uplift Approval Request

  • User impact if declined: Square avatar image in fxa menu when they change their password.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This change only removes one css variable which resets the avatar image.
  • String changes made/needed:
Flags: needinfo?(vbudhram)
Attachment #9099631 - Flags: approval-mozilla-beta?
Attachment #9094607 - Flags: approval-mozilla-beta?
Comment on attachment 9099631 [details] [diff] [review]
avatar_disconnect_patch.diff

Is this needed? Looks like the fix is in the other attachment and you can obsolete this attachment.
Attachment #9099631 - Flags: approval-mozilla-beta? → approval-mozilla-beta-

Comment on attachment 9094607 [details]
Bug 1580115 - Fix fxa menu disconnected avatar

Polish fix, seems best to keep the icon consistent. OK for beta 14 uplift.

Attachment #9094607 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I verified this issue on Beta 70.0b14 on Mac OS X 10.14, Windows 10 and Ubuntu 18.04 and the results are the same as in comment 6, the shape of the icon is not changed but the functionality of the feature was changed after this fix.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.