If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[perf] Closing address book card dialog slow

VERIFIED FIXED in M12

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Michael Lowe, Assigned: hangas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: {perf})

(Reporter)

Description

18 years ago
After opening the new address book card dialog (File/New/Address Book Card menu
in the browser), clicking on the cancel button causes a crash (1999100708
build).

In previous builds it didn't crash, but took quite a large ammount of time to
complete the close.

Maybe both of these issues are related.
(Reporter)

Updated

18 years ago
Whiteboard: {perf}
(Assignee)

Comment 1

18 years ago
Hmmm...Esther have you seen this?  I will try to get a PC build and test it also.
Status: NEW → ASSIGNED
Target Milestone: M11
(Reporter)

Updated

18 years ago
Severity: critical → normal
Summary: Crash closing address book card dialog → [perf] Closing address book card dialog slow
(Reporter)

Comment 2

18 years ago
Crash does not occur in latest build, but closing dialog is still slow.
Probably caused by the large number of edit fields.
(Assignee)

Comment 3

18 years ago
The performance of the input fields is a problem with GFX input fields and
happens on all platforms.  The Porkjockey team is looking at this.

Updated

18 years ago
OS: Windows NT → All
Hardware: PC → All

Comment 4

18 years ago
OK, I'm a little late with input so I am not seeing the crash but I am seeing he
very slow oepning and closing of the Edit card dialog on all platforms using
19991012M11 builds.
Very slow for win32 400mhz is 4 sec to open 5 sec to close.
Very slow for linux 166 system is 20 sec to open 25 sec to close
Very slow for mac G3 system is 4 sec to open 5 sec to close.
Changing to Platforms and OS to All
(Assignee)

Comment 5

18 years ago
Moving to M12.
(Reporter)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

18 years ago
Now fixed

Updated

18 years ago
QA Contact: lchiang → esther

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
Using M11 builds 1999111218 on Win98 and linux and 1999111111m11 on Mac this is
fixed.  I know these aren't M12 builds (target fix was for M12) but the reporter
states it's fixed s maybe this was fixed by some other M11 bug fix.  Verified
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.