Closed Bug 1580604 Opened 1 year ago Closed 1 year ago

Reloading about:newtab shows blank page until resizing window or switching applications

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: Mardak, Assigned: kmag)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Setting fission.rebuild_frameloaders_on_remoteness_change to false avoids the problem

STR:

  1. open new tab
  2. reload the page

expect: new tab content

actual: blank page

Flags: needinfo?(kmaglione+bmo)
Assignee: nobody → kmaglione+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(kmaglione+bmo)
Priority: -- → P1
See Also: → 1580527

Only reproduces for me the first time I refresh. If I then close the new tab and then try, it doesn't repro.
NI'ing Kris since it's a regression from the frameloader rebuilding pref, and also Matt in case there is an obvious rendering timing issue here.

Flags: needinfo?(matt.woodrow)
Flags: needinfo?(kmaglione+bmo)
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5adc25f92618
Pref off non-Fission frameloader rebuilding by default again. r=nika
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(kmaglione+bmo)
Blocks: 1583614
Flags: qe-verify+

Issue reproducible with Fx 71.0b7 and Nightly 72.0a1.
When pref fission.rebuild_frameloaders_on_remoteness_change is set to "true" about:newtab is blank until window is resized.

Flags: needinfo?(kmaglione+bmo)
Flags: qe-verify+

(In reply to Gabi Cheta [:Gabi] Release Desktop QA from comment #5)

Issue reproducible with Fx 71.0b7 and Nightly 72.0a1.
When pref fission.rebuild_frameloaders_on_remoteness_change is set to "true" about:newtab is blank until window is resized.

The pref has been a default since Fx73 and no new issues were reported. Please NI me if you still see an issue.

Flags: needinfo?(kmaglione+bmo)
You need to log in before you can comment on or make changes to this bug.