Closed Bug 1580973 Opened 7 months ago Closed 5 months ago

Assertion failure: false (Trying to attach to out of process parent context), at src/dom/ipc/ContentParent.cpp:5815

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1581076
Tracking Status
firefox71 --- disabled

People

(Reporter: tsmith, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, crash, testcase)

Attachments

(1 file)

Attached file testcase.html

Reduced with m-c:
BuildID=20190911160523
SourceStamp=ba563f823a564dfade0327d003143d765ac9ab59

Testcase requires fission.autostart=true and must be served via a webserver.

Assertion failure: false (Trying to attach to out of process parent context), at src/dom/ipc/ContentParent.cpp:5815

#0 mozilla::dom::ContentParent::RecvAttachBrowsingContext(mozilla::dom::BrowsingContext::IPCInitializer&&) src/dom/ipc/ContentParent.cpp:5806:5
#1 mozilla::dom::PContentParent::OnMessageReceived(IPC::Message const&) src/obj-firefox/ipc/ipdl/PContentParent.cpp:10970:57
#2 mozilla::ipc::MessageChannel::DispatchAsyncMessage(mozilla::ipc::ActorLifecycleProxy*, IPC::Message const&) src/ipc/glue/MessageChannel.cpp:2185:25
#3 mozilla::ipc::MessageChannel::DispatchMessage(IPC::Message&&) src/ipc/glue/MessageChannel.cpp:2109:9
#4 mozilla::ipc::MessageChannel::RunMessage(mozilla::ipc::MessageChannel::MessageTask&) src/ipc/glue/MessageChannel.cpp:1954:3
#5 mozilla::ipc::MessageChannel::MessageTask::Run() src/ipc/glue/MessageChannel.cpp:1985:13
#6 nsThread::ProcessNextEvent(bool, bool*) src/xpcom/threads/nsThread.cpp:1225:14
#7 NS_ProcessNextEvent(nsIThread*, bool) src/xpcom/threads/nsThreadUtils.cpp:486:10
#8 mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) src/ipc/glue/MessagePump.cpp:88:21
#9 MessageLoop::RunInternal() src/ipc/chromium/src/base/message_loop.cc:315:10
#10 MessageLoop::Run() src/ipc/chromium/src/base/message_loop.cc:290:3
#11 nsBaseAppShell::Run() src/widget/nsBaseAppShell.cpp:137:27
#12 nsAppStartup::Run() src/toolkit/components/startup/nsAppStartup.cpp:276:30
#13 XREMain::XRE_mainRun() src/toolkit/xre/nsAppRunner.cpp:4585:22
#14 XREMain::XRE_main(int, char**, mozilla::BootstrapConfig const&) src/toolkit/xre/nsAppRunner.cpp:4720:8
#15 XRE_main(int, char**, mozilla::BootstrapConfig const&) src/toolkit/xre/nsAppRunner.cpp:4801:21
#16 do_main(int, char**, char**) src/browser/app/nsBrowserApp.cpp:218:22
#17 main src/browser/app/nsBrowserApp.cpp:300:16
Flags: in-testsuite?

The priority flag is not set for this bug.
:jimm, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jmathies)
Flags: needinfo?(jmathies) → needinfo?(nkochar)
Status: NEW → RESOLVED
Closed: 5 months ago
Component: DOM: Content Processes → DOM: Core & HTML
Flags: needinfo?(nkochar)
Resolution: --- → DUPLICATE
Duplicate of bug: 1581076
You need to log in before you can comment on or make changes to this bug.