Closed Bug 1581283 Opened 2 years ago Closed 2 years ago

Remove focus rect around the search result list

Categories

(DevTools :: Netmonitor, defect, P3)

All
Unspecified
defect

Tracking

(firefox71 verified)

VERIFIED FIXED
Firefox 71
Tracking Status
firefox71 --- verified

People

(Reporter: Honza, Assigned: lloanalas)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(2 files)

Attached image image.png

The list of search results (in the Search Panel) should not have focus rect.

STR:

  1. Load any page (e.g. google.com)
  2. Open the Search panel and perform a search that produces some matches/results
  3. Whil being in the search input box press tab key several times to focus the list of results
  4. Check out the focus rect -> BUG

Honza

@honza

I actually can't replicate this? Can you try this one again and see if it was fixed maybe?

Flags: needinfo?(odvarko)

I can still reproduce on Win10 and MacOS

While you are in the input box
press the tab key to move to Clear button (within the input),
press again to move to case-sensitive button
press again to move to the Close Search panel button
press again to move to the content with search result.

Now you should see a focus rect within the content around all search results.
This rect should not be there.

Honza

Flags: needinfo?(odvarko)
Flags: needinfo?(lloanalas)
Duplicate of this bug: 1585666

Thanks @honza, taking a look shortly.

Flags: needinfo?(lloanalas)
Assignee: nobody → lloanalas
Status: NEW → ASSIGNED
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0409aaf10a05
Remove focus rect around the search result list. r=Honza.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Verified with 71.0a1 (2019-10-13).
No more focus ring.

Status: RESOLVED → VERIFIED
Hardware: Unspecified → All
You need to log in before you can comment on or make changes to this bug.