Closed Bug 1581415 Opened 4 months ago Closed 4 months ago

[protection panel] can be cut off at bottom if the social tracking category is taking up more than one line

Categories

(Firefox :: Protections UI, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox69 --- unaffected
firefox70 + verified
firefox71 --- verified

People

(Reporter: aryx, Assigned: johannh)

References

Details

(Keywords: regression, Whiteboard: [privacy-panel][skyline])

Attachments

(3 files)

Firefox 70.0b6 on Windows 8.1

The protection panel can be cut off at bottom if two tracking categories have to used two lines. I saw it but now that I want to take a screenshot, the issue is gone.

The last line with the options to open the protection report and the counter for the trackers blocked were almost completely hidden.

Whiteboard: [privacy-panel][skyline]

Johann said he can look into this since he might have seen this on Windows too.

Flags: needinfo?(jhofmann)

Oana found a way to reproduce the same symptoms in bug 1582750 with these STR:

  • Place the browser on the lower half of the screen.
  • Open any site with a new profile or click on the shield icon from URL bar and then on the "i" symbol.
  • Observe the "Browse without being followed" panel.

She further notes:

This happens sometimes when you open the browser for the first time. I just logged the issue under this steps, because following these steps the issue is always reproducing.

Which might be the same thing that's happening here.

I can reproduce this on Windows 10 with the German locale and I have a vague idea on how to fix it...

Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)
Priority: -- → P1
See Also: → 1582750

I managed to fix this, but bug 1582750 and this issue are different, I believe.

See Also: → 1564077

[Tracking Requested - why for this release]:
Slightly broken Skyline/protections panel UI on popular locales

Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/33f45301333c
Add missing wrap attributes to toolbarbuttons in the protections panel. r=nhnt11
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Can you request uplift? Thanks!

Flags: qe-verify+

We tried to reproduce this issue using Windows 8.1, but we couldn't manage.
Can you please provide us with some steps or at least how did you manage to have two tracking categories that have to used two lines.

Flags: needinfo?(aryx.bugmail)
  1. Download Firefox Beta in German from https://www.mozilla.org/de/firefox/all/#product-desktop-beta
  2. Install it.
  3. Load https://www.welt.de/
  4. Click the shield icon in the url bar.
Flags: needinfo?(aryx.bugmail)

Comment on attachment 9094555 [details]
Bug 1581415 - Add missing wrap attributes to toolbarbuttons in the protections panel. r=nhnt11

Beta/Release Uplift Approval Request

  • User impact if declined: Slightly broken Skyline/protections panel UI on popular locales
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 10
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Super low risk, just adding a few missing attributes to markup.
  • String changes made/needed: None
Attachment #9094555 - Flags: approval-mozilla-beta?

Comment on attachment 9094555 [details]
Bug 1581415 - Add missing wrap attributes to toolbarbuttons in the protections panel. r=nhnt11

Minor fix for skyline feature, fine for uplift for beta 10.

Attachment #9094555 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
Summary: [protection panel] can be cut off at bottom if two tracking categories have to used two lines → [protection panel] can be cut off at bottom if the social tracking category is taking up more than one line

I managed to reproduce the issue using Firefox 70.0b8 on Windows 10 x64.
I tested with the last Nightly 71.0a1 and the bug is not reproducing.
The bug will be closed after I will test the fix on the beta that will be released Friday.

I think that this issue might be intermittent, because I managed to reproduce it again on the same build and same profile I used as in comment 14.
Should we file a new bug or will you reopen this one?

Flags: needinfo?(jhofmann)

Can you provide a screencast by any chance?

Flags: needinfo?(jhofmann) → needinfo?(oana.botisan)

This is reproduced on the latest Nightly. What is interesting is that until this point I couldn't reproduce the issue, now it's reproducing all the time.

Flags: needinfo?(oana.botisan)

I can't reproduce this anymore :(

Are you sure you're on the very latest Nightly, i.e. for 09/24?

Yes. This is the build: 71.0a1 (2019-09-24) (64-Bit).

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

I managed to reproduce the issue using this site on Firefox 70.0b10 and latest Nightly 71.0a1.
Should we reopen this bug or should I log another one?

Flags: needinfo?(jhofmann)

(In reply to Oana Botisan, Desktop Release QA from comment #21)

I managed to reproduce the issue using this site on Firefox 70.0b10 and latest Nightly 71.0a1.
Should we reopen this bug or should I log another one?

Please wait for the next Nightly - we think we fixed this permanently in bug 1582750.

Flags: needinfo?(jhofmann)

To be clear, maybe this is indeed still an issue - but IMO we should wait till the next Nightly to see if that bug helps.

Also re-requesting ni? from Johann - I canceled in the interest of saving him some time but then I figured it's important for people to speak for themselves.

Flags: needinfo?(jhofmann)

Seconding what Nihanth said, please check again in the Nightly that has the fix for bug 1582750, this should probably be completely fixed now.

Flags: needinfo?(jhofmann)

I've checked again in latest Nightly 71.0a1 (20191008214557) on a "de" build, and unfortunately the issue is still reproducible. It looks like I cannot reproduce it by following the exact steps from comment 10, but using these steps and the ones from Oana's comment 17, the issue is present.

  1. Download a “de” build from https://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central-l10n/
  2. Install it and launch the browser with a clean profile.
  3. Load https://www.welt.de/ in a new tab.
  4. Wait until the site is fully loaded and click on the shield icon.
  5. Refresh the webpage.

Nihanth, what would be the best approach here, should we reopen this bug, or file another one with the slightly modified steps?

Flags: needinfo?(nhnt11)
Attached image Screenshot

Ciprian, what platform are you on - Windows? I can't reproduce on Mac, see the attached screenshot.

Flags: needinfo?(nhnt11) → needinfo?(ciprian.georgiu)

Yes, you're right. I can't reproduce it on macOS 10.13.6 either, nor on Ubuntu 18.0 x64.

I'm on Windows 10 x64, it looks like the issue is specific to this OS; I was able to see the bug on Windows 7 x64 as well.

Let me know please, Nihanth if you have any luck in reproducing this on Win.

Flags: needinfo?(ciprian.georgiu) → needinfo?(nhnt11)

I think we can close this as verified fixed, since Oana filed bug 1589015 for the remaining part mentioned in comment 27.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(nhnt11)
You need to log in before you can comment on or make changes to this bug.