Closed Bug 1581477 Opened 5 months ago Closed 2 months ago

Mochitests fail when Fission on under no-sw-e10s mode, but pass under sw-e10s.

Categories

(Core :: DOM: Service Workers, defect, P2)

defect

Tracking

()

RESOLVED WORKSFORME
Fission Milestone M4.1

People

(Reporter: edenchuang, Assigned: edenchuang)

References

(Blocks 1 open bug)

Details

Crash Data

Attachments

(2 files)

Following mochitests fail with Fission under the non-sw-e10s mode, but pass under the sw-e10s mode

dom/serviceworkers/test/test_csp_upgrade-insecure_intercept.html
dom/serviceworkers/test/test_hsts_upgrade_intercept.html
dom/serviceworkers/test/test_https_fetch.html
dom/serviceworkers/test/test_https_fetch_cloned_response.html
dom/serviceworkers/test/test_https_synth_fetch_from_cached_sw.html
dom/serviceworkers/test/test_importscript_mixedcontent.html
dom/serviceworkers/test/test_third_party_iframes.html

All function checks are passed, but the test environment complains that the service worker is not cleaned up after calling SimpleTest.finish().

Andrew, since we are turning on sw-e10s mode in nightly, do you think need we fix this bug at the moment? Or we just let it be fixed by turning on sw-e10s?

Flags: needinfo?(bugmail)
Assignee: nobody → echuang
Status: NEW → ASSIGNED
Fission Milestone: --- → M4
Priority: -- → P2

After fixed bug 1542415, following mochitests get into the same situation.

dom/serviceworkers/test/test_https_origin_after_redirect.html
dom/serviceworkers/test/test_https_origin_after_redirect_cached.html

Let the bugs be fixed by turning on sw-e10s.

Flags: needinfo?(bugmail)

(In reply to Andrew Sutherland [:asuth] (he/him) from comment #2)

Let the bugs be fixed by turning on sw-e10s.

Yeah, we've already decided that sw-e10s is going to be required for Fission, and Fission mochitests are now running exclusively with sw-e10s and DocumentChannel enabled.

Currently, sw-e10s is on in default in nightly. I am going to enable the failed tests to see if they still fail with enable-fission.

Eden, can all the tests that were waiting for sw-e10s pref now be enabled? I believe there are at least 8 tests in this category.

Flags: needinfo?(echuang)

Hello Neha, Yes, I tested them, most of these can be passed on try, I will land a patch to enable them later.

Flags: needinfo?(echuang)

After sw-e10s enabled in nightly, following tests should be passsed with Fission

dom/serviceworkers/test/browser_devtools_serviceworker_interception.js
dom/serviceworkers/test/test_cookie_fetch.html
dom/serviceworkers/test/test_csp_upgrade-insecure_intercept.html
dom/serviceworkers/test/test_eventsource_intercept.html
dom/serviceworkers/test/test_hsts_upgrade_intercept.html
dom/serviceworkers/test/test_https_fetch.html
dom/serviceworkers/test/test_https_fetch_cloned_response.html
dom/serviceworkers/test/test_https_origin_after_redirect.html
dom/serviceworkers/test/test_https_origin_after_redirect_cached.html
dom/serviceworkers/test/test_https_synth_fetch_from_cached_sw.html
dom/serviceworkers/test/test_importscript_mixedcontent.html
dom/serviceworkers/test/test_sanitize_domain.html

This patch enables these tests.

Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/243d10dad9d8
Enable dom/serviceworkers/test mochitests for fission r=perry

Keywords: checkin-needed

Roll unfixed test bugs from Fission Milestone M4 to M4.1

Fission Milestone: M4 → M4.1
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dae278cd682d
enable dom/serviceworkers/test/test_third_party_iframes.html for fission r=dom-workers-and-storage-reviewers,perry
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 1584471
Crash Signature: [@ mozilla::dom::WindowGlobalParent::Init(mozilla::dom::WindowGlobalInit const &)]
You need to log in before you can comment on or make changes to this bug.