Closed Bug 1581577 Opened 5 months ago Closed 5 months ago

Hostname obfuscation ICE duration telemetry is being reported in milliseconds, not seconds

Categories

(Core :: WebRTC, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox70 --- fixed
firefox71 --- fixed

People

(Reporter: dminor, Assigned: dminor)

References

Details

Attachments

(1 file)

When I added the hostname obfuscation ICE duration telemetry in Bug 1569250, I intended for it to be reported in seconds and set the "high" value accordingly, but used the Telemetry::AccumulateTimeDelta call to report it, which reports in milliseconds.

The Telemetry::AccumulateTimeDelta function reports in milliseconds but I had
assumed seconds when I added the hostname obfuscation ICE duration histogram.
This change adjusts the "high" value accordingly.

With the telemetry we've collected to date, 60% of the values are below 600
milliseconds, so I think that setting a high value of 30 seconds should be
sufficient even if there is a long tail. Since this does not change the data
being collected, no additional data-review is required, but it does require
renaming the key.

Assignee: nobody → dminor
Status: NEW → ASSIGNED
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2591b1d2429d
Fix ICE duration telemetry high value; r=bwc
Priority: -- → P2
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Comment on attachment 9093076 [details]
Bug 1581577 - Fix ICE duration telemetry high value; r=bwc!

Beta/Release Uplift Approval Request

  • User impact if declined: This fixes the telemetry added in Bug 1581577 to have a proper high value for the ice duration, without this, we won't have the full range of values visible in telemetry which would make it harder to determine if enabling hostname obfuscation causes problems.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1569250
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This just changes a telemetry probe. It has been checked on Nightly already.
  • String changes made/needed: None
Attachment #9093076 - Flags: approval-mozilla-beta?

Comment on attachment 9093076 [details]
Bug 1581577 - Fix ICE duration telemetry high value; r=bwc!

Follow-up fix for bug 1569250. Approved for 70.0b8.

Attachment #9093076 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.