Closed Bug 1581722 Opened 4 months ago Closed 2 months ago

Intermittent toolkit/content/tests/chrome/test_bug437844.xhtml,test_bug437844.xul | assertion count 55 is more than expected 14 to 54 assertions

Categories

(Toolkit :: General, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed
firefox72 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: dluca)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(2 files)

Filed by: rgurzau [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=266979294&repo=autoland
Full log: https://queue.taskcluster.net/v1/task/QhAFupo-RMyYW_2Hp7USEw/runs/0/artifacts/public/logs/live_backing.log


[task 2019-09-17T05:20:56.512Z] 05:20:56 INFO - GECKO(5200) | #74: nsBaseAppShell::Run() [widget/nsBaseAppShell.cpp:139]
[task 2019-09-17T05:20:56.512Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.512Z] 05:20:56 INFO - GECKO(5200) | #75: nsAppShell::Run() [widget/windows/nsAppShell.cpp:406]
[task 2019-09-17T05:20:56.512Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.512Z] 05:20:56 INFO - GECKO(5200) | #76: nsAppStartup::Run() [toolkit/components/startup/nsAppStartup.cpp:277]
[task 2019-09-17T05:20:56.513Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.513Z] 05:20:56 INFO - GECKO(5200) | #77: XREMain::XRE_mainRun() [toolkit/xre/nsAppRunner.cpp:4600]
[task 2019-09-17T05:20:56.513Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.513Z] 05:20:56 INFO - GECKO(5200) | #78: XREMain::XRE_main(int,char * * const,mozilla::BootstrapConfig const &) [toolkit/xre/nsAppRunner.cpp:4735]
[task 2019-09-17T05:20:56.513Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.513Z] 05:20:56 INFO - GECKO(5200) | #79: XRE_main(int,char * * const,mozilla::BootstrapConfig const &) [toolkit/xre/nsAppRunner.cpp:4816]
[task 2019-09-17T05:20:56.513Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.513Z] 05:20:56 INFO - GECKO(5200) | #80: mozilla::BootstrapImpl::XRE_main(int,char * * const,mozilla::BootstrapConfig const &) [toolkit/xre/Bootstrap.cpp:45]
[task 2019-09-17T05:20:56.513Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.514Z] 05:20:56 INFO - GECKO(5200) | #81: NS_internal_main(int,char * *,char * *) [browser/app/nsBrowserApp.cpp:300]
[task 2019-09-17T05:20:56.514Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.514Z] 05:20:56 INFO - GECKO(5200) | #82: wmain [toolkit/xre/nsWindowsWMain.cpp:131]
[task 2019-09-17T05:20:56.514Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.514Z] 05:20:56 INFO - GECKO(5200) | #83: static int __scrt_common_main_seh() [f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:288]
[task 2019-09-17T05:20:56.514Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.514Z] 05:20:56 INFO - GECKO(5200) | #84: kernel32.dll + 0x4ef3c
[task 2019-09-17T05:20:56.514Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.515Z] 05:20:56 INFO - GECKO(5200) | #85: ntdll.dll + 0x63618
[task 2019-09-17T05:20:56.515Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.515Z] 05:20:56 INFO - GECKO(5200) | #86: ntdll.dll + 0x635eb
[task 2019-09-17T05:20:56.515Z] 05:20:56 INFO -
[task 2019-09-17T05:20:56.515Z] 05:20:56 INFO - GECKO(5200) | MEMORY STAT | vsize 882MB | vsizeMaxContiguous 439MB | residentFast 333MB | heapAllocated 124MB
[task 2019-09-17T05:20:56.515Z] 05:20:56 INFO - GECKO(5200) | JavaScript error: , line 0: uncaught exception: [fluent][resolver] errors in en-US/file-dd: ReferenceError: Unknown variable: $pluginLibraries.
[task 2019-09-17T05:20:56.515Z] 05:20:56 INFO - TEST-OK | toolkit/content/tests/chrome/test_bug437844.xul | took 2265ms
[task 2019-09-17T05:20:56.516Z] 05:20:56 INFO - GECKO(5200) | ++DOMWINDOW == 86 (0F74A400) [pid = 5220] [serial = 123] [outer = 1C50FA60]
[task 2019-09-17T05:20:56.516Z] 05:20:56 INFO - TEST-UNEXPECTED-FAIL | toolkit/content/tests/chrome/test_bug437844.xul | assertion count 55 is more than expected 14 to 54 assertions
[task 2019-09-17T05:20:56.516Z] 05:20:56 INFO - TEST-START | toolkit/content/tests/chrome/test_bug451540.xul
[task 2019-09-17T05:20:56.516Z] 05:20:56 INFO - GECKO(5200) | ++DOMWINDOW == 87 (008DAC00) [pid = 5220] [serial = 124] [outer = 1C50FA60]

Summary: Intermittent toolkit/content/tests/chrome/test_bug437844.xul | assertion count 55 is more than expected 14 to 54 assertions → Intermittent toolkit/content/tests/chrome/test_bug437844.xhtml,test_bug437844.xul | assertion count 55 is more than expected 14 to 54 assertions
Duplicate of this bug: 1597833

I've looked at the logs for the recent 56-failure spike and it appears to be the same assertions as before, just hitting in different numbers (we didn't introduce a new assertion into the mix that wasn't previously there). I think we can just bump the annotation.

This test is pretty known-flaky from the looks of its history.

See Also: → 1587850
Pushed by rvandermeulen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bfe4bccb6730
Expand expected assertions range for test_bug437844.xul for m-c. a=RyanVM r=RyanVM
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.