Closed Bug 1582080 Opened 5 years ago Closed 10 months ago

Expanding event object causes warning message: "MouseEvent.mozPressure is deprecated. Use PointerEvent.pressure instead."

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 860312

People

(Reporter: Honza, Unassigned)

References

(Blocks 1 open bug)

Details

STR:

  1. Load http://janodvarko.cz/xhr-spy/
  2. Create Mouse -> click DOM BP
  3. Check the Log checkbox
  4. Click on the page
  5. Check out the Console panel, there should be three click logs
  6. Expand and collapse the first log
  7. You should see MouseEvent.mozPressure is deprecated. Use PointerEvent.pressure instead. warning -> BUG

ER: the warning shouldn't be there

Honza

Note that logging on events was introduced in bug 1110276

Honza

This isn't related to logpoints, as the following STR would produce the same effect:

  1. Navigate to data:text/html,<meta charset=utf8><script>document.addEventListener("click", console.log)</script>
  2. Click on the page
  3. Open the console
  4. Expand the logged object in the console

I know for sure that we already have a bug for that, but I can't find it anymore. Basically it's because we iterate over the object when retrieving the properties, which makes the engine emit those warnings. We discussed in the other bug trying to filter out these messages from the console by looking at their stack.

Summary: DOM Mutation Logs should not log "MouseEvent.mozPressure is deprecated. Use PointerEvent.pressure instead." → Expanding event object causes warning message: "MouseEvent.mozPressure is deprecated. Use PointerEvent.pressure instead."
Severity: normal → S3

I think this is a duplicate of bug 860312

Flags: needinfo?(nchevobbe)

(In reply to Mathew Hodson from comment #3)

I think this is a duplicate of bug 860312

indeed :)

Status: NEW → RESOLVED
Closed: 10 months ago
Duplicate of bug: 860312
Flags: needinfo?(nchevobbe)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.