Closed Bug 1582081 Opened 3 months ago Closed 3 months ago

2.04 - 2.24% startup_about_home_paint_realworld_webextensions (linux64-shippable, linux64-shippable-qr) regression on push 7debf9ae76429743601855581e84b63ed917af23 (Tue September 17 2019)

Categories

(Firefox :: Search, defect, P1)

69 Branch
defect
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 71
Iteration:
71.2 - Sept 16 - 29
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed
firefox71 --- fixed

People

(Reporter: marauder, Assigned: standard8)

References

(Regression)

Details

(4 keywords)

Attachments

(1 file)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=7debf9ae76429743601855581e84b63ed917af23

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

2% startup_about_home_paint_realworld_webextensions linux64-shippable opt e10s stylo 756.58 -> 773.50
2% startup_about_home_paint_realworld_webextensions linux64-shippable-qr opt e10s stylo 1,285.62 -> 1,312.25
2% startup_about_home_paint_realworld_webextensions linux64-shippable-qr opt e10s stylo 1,288.58 -> 1,314.83

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=23113

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/TestEngineering/Performance/Talos

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/TestEngineering/Performance/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/TestEngineering/Performance/Talos/RegressionBugsHandling

Component: Performance → Search
Flags: needinfo?(standard8)
Product: Testing → Firefox
Target Milestone: --- → Firefox 71
Version: Version 3 → 69 Branch

There's a few issues in my patch for bug 1578807 that I didn't pick up when writing it, and that is causing the search engine cache to be rebuilt on each startup.

That's probably enough to cause this.

Assignee: nobody → standard8
Status: NEW → ASSIGNED
Flags: needinfo?(standard8)
Priority: -- → P1
Regressed by: 1578807

Thanks for updates, Mark!

Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2b4d285d8caa
Fix detection of builtin engines in the search cache. r=daleharvey
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

From what I can tell, looks like this fixed the perf regressions.

Comment on attachment 9093587 [details]
Bug 1582081 - Fix detection of builtin engines in the search cache. r?daleharvey

Beta/Release Uplift Approval Request

  • User impact if declined: If the user gets into a broken cache state, they might not be able to get out of it until the next release, without manually removing files.

This also adds telemetry so we can check how often it is occurring.

Note: this fixes some mistakes in the original patch and also fixes the automatic tests since it wasn't testing exactly what was intended.

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1578807
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Worst case we'll be doing extra rebuilds of the cache on startup.
  • String changes made/needed: None
Attachment #9093587 - Flags: approval-mozilla-beta?

Comment on attachment 9093587 [details]
Bug 1582081 - Fix detection of builtin engines in the search cache. r?daleharvey

Follow-up fix for bug 1578807. Approved for 70.0b8.

Attachment #9093587 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Iteration: --- → 71.2 - Sept 16 - 29
Points: --- → 1
You need to log in before you can comment on or make changes to this bug.