Can't import address book from text file if its name is non-ascii

RESOLVED DUPLICATE of bug 151162

Status

MailNews Core
Internationalization
RESOLVED DUPLICATE of bug 151162
16 years ago
2 years ago

People

(Reporter: Jeesun Cho, Assigned: nhottanscp)

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Can't import address book from ldif file if its name is non-ascii
Build: 0718 branch build
Observed on: En windows XP, JA windows XP, JA linux

Steps:
1. Go to Tools|Import
2. Select Address Books and hit next
3. Select Text file and hit next
4. Choose a ldif file with Japanese name and click open
5. It brings up a window which allows user to select address book fields.
Actually, according to feature spec, this screen is supposed to come up for tab,
cvs, txt type of files, not for ldif files. 
6. Anyway, click on OK button
7. The last screen says:
Addresses successfully imported from Text file. 
No address books were found to import
8. AB isn't imported.
(Reporter)

Comment 1

16 years ago
The ldif file names I tried were (see this with Shift_JIS):
ぃんご.ldif, さんぽ.ldif

Note: Ldif files with Latin-1 name do not show this problem
Keywords: intl
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Depends on: 157010
(Assignee)

Updated

16 years ago
Blocks: 157010
No longer depends on: 157010
Target Milestone: --- → mozilla1.2alpha
(Reporter)

Comment 2

16 years ago
QA contact over to me.
Nominate this bug.
Keywords: nsbeta1
QA Contact: marina → jeesun
(Reporter)

Comment 3

16 years ago
Problem exists when other text file type were used. Change the summary accordingly.
Summary: Can't import address book from ldif file if its name is non-ascii → Can't import address book from text file if its name is non-ascii
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.2alpha → ---

Comment 4

16 years ago
*** Bug 175342 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
Please see related bug 151162

Comment 6

16 years ago
changing qa contact
QA Contact: jeesun → marina

Comment 7

15 years ago
i18n triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Product: MailNews → Core

Comment 8

14 years ago

*** This bug has been marked as a duplicate of 151162 ***
No longer blocks: 157010
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core

Comment 9

2 years ago
[Tracking Requested - why for this release]:
tracking-b2g: --- → backlog
Flags: needinfo?(kiandresmith7)

Comment 10

2 years ago
This is not the place for your testing.
Please use https://landfill.bugzilla.org/ for your testing.
tracking-b2g: backlog → ---
Flags: needinfo?(kiandresmith7)
You need to log in before you can comment on or make changes to this bug.