News items in center of page not document.written() by external JS scripts with Unicode URLs

VERIFIED DUPLICATE of bug 137182

Status

()

Core
Networking: HTTP
VERIFIED DUPLICATE of bug 137182
16 years ago
16 years ago

People

(Reporter: Qu Ning, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

331 bytes, text/html
Details
(Reporter)

Description

16 years ago
In fact, in this pages, news are listed,
but they are disappeared in mozilla. Perhaps
it's unreadable for you because this page is for
chinese, but it the news center of the best 
university (beida, you know?)in china, so many people
will go there every day. So I think it's better 
debug it for us, thank you at all!!

Comment 1

16 years ago
Created attachment 91907 [details]
testcase

Comment 2

16 years ago
according to my testcase, this bug has nothing to do with table.
Component: HTMLTables → Layout

Comment 3

16 years ago
this bug has nothing to do with table,according to my testcase.

Comment 4

16 years ago
*** Bug 158249 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
This is not a Layout problem. The middle of the page is created by external 
JavaScript files that document.write() the HTML content.

The problem is the Unicode characters in the URL of the external script.
The reduced testcase above is by taking just one of the external scripts:

<script language=javascript 
src="http://pkunews.pku.edu.cn/newslink1.php?type=½ÌÓýÊÓµã&item=10&width=52">
</script>


This is supposed to document.write() HTML content to the page.
Here is some of the source of that <script> file:

document.write('');
document.write('');
document.write('ÍõµÇ·å£º¶«Î÷·½ÎÄ.....');


                       etc.
                       etc.


All this is missing from the main site, since none of these external
<script>'s load properly, and the document.write()'s do not occur.

Reassigning to Networking component; we have to be able to 
handle URLs with extended characters, right?
Assignee: karnaze → darin
Status: UNCONFIRMED → NEW
Component: Layout → Networking: HTTP
Ever confirmed: true
QA Contact: amar → tever

Comment 6

16 years ago
cc'ing jst for advice: is this another duplicate of bug 137182,
"javascript: URL's with non-UTF-8 characters not working"?

Or is this different, since it involves <script src=URL>?
It's the same thing, really, isn't it?
Summary: many news list in it disappear in mazilla → News items in center of page not document.written() by external JS scripts with Unicode URLs
Yup, this is a dupe of bug 137182.

*** This bug has been marked as a duplicate of 137182 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

16 years ago
my problem no resolved, that page is view not ok after i 
update to 0720 version!!
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
reduping

bug 137182 is still not fixed. Please reopen only if bug 137182 and you see it
with a build one day after the fix.


*** This bug has been marked as a duplicate of 137182 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
You need to log in before you can comment on or make changes to this bug.