Would be great to extend IMAGE BLOCKING to block DIFFERENT types of resources (FLASH etc.)

VERIFIED DUPLICATE of bug 94035

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 94035
16 years ago
14 years ago

People

(Reporter: an-tin, Assigned: morse)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

IMAGE BLOCKING : block ANY type of resource. Editable entry in list of blocking
e.g. 
  <block url="*.ads.com" types=".gif;.png;.swf;.shtml"> or better
  <block url="*.*ads*.*" types=".gif;.png;.swf;.*html">
instead of 
  .ads.com  1F
Such a feature will give powerful protektion from undesired content like
agressive ADS (especially FLASH). Why this entries should be editable by hands :
because some systems use redirect from one place to another and threre is no way
to block the source of content itself from browser.
E.g. in HTML we have <img src="http://www.ads.com?something">, but this is just
dispatcher to redirect to 100 another servers. So, I have to block DISPATCHER,
but I can never have page with URL http://www.ads.com?something be opened in
browser because of redirect.


Reproducible: Always
Steps to Reproduce:
1. Enter any website with agressive FLASH ADS.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 94035 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: tever → nobody
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.