Closed Bug 1582967 Opened 1 year ago Closed 1 year ago

Rename brower-prefs.js file and move pref files to suite/app/profile

Categories

(SeaMonkey :: Build Config, task)

task
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.68
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Details

(Whiteboard: SM2.53.1)

Attachments

(1 file)

SeaMonkey's pref file is currently called browser-prefs.js but actually includes prefs for the whole suite so should be renamed to something more appropriate (suite-prefs.js) and moved into suite/app/profile which mirrors what TB and FX do.
Also whilst here let's move channel-prefs.js into suite/app/profile too.

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: None
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Attachment #9094405 - Flags: review?(frgrahl)
Attachment #9094405 - Flags: approval-comm-release?
Attachment #9094405 - Flags: approval-comm-esr60?
Comment on attachment 9094405 [details] [diff] [review]
Move and rename prefs files

lgtm
Attachment #9094405 - Flags: review?(frgrahl)
Attachment #9094405 - Flags: review+
Attachment #9094405 - Flags: approval-comm-release?
Attachment #9094405 - Flags: approval-comm-release+
Attachment #9094405 - Flags: approval-comm-esr60?
Attachment #9094405 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/433afb979a4e
Rename brower-prefs.js file and pref files to suite/app/profile. r=frg

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Summary: Rename brower-prefs.js file and pref files to suite/app/profile → Rename brower-prefs.js file and move pref files to suite/app/profile
Whiteboard: SM2.53.1
You need to log in before you can comment on or make changes to this bug.