This is an old problem that tends to haunt us from time to time.
Suite/test names for perf tests can get very big, ugly & hard to read.
Renaming them disconnects the data points.
Warning: implementation details bellow! May turn out to be a bad track!
I think we should treat the suite/test names we already have as untouchable. Don't ever try to rename them, even if they have a typo.
Then create the concept of public suite/test names. Renaming them won't disconnect the data points. But it will reflect in all Perfherder's views, improving readability for them by a lot (where needed).
For this to work, I think a new table with a max of 4 fields like
public_test_name would do the trick.
initial_test could be indexed & treated as a composite unique key, for faster joins.
initial_test are basically foreign keys pointing to our existing suite & test names.