Closed Bug 1583566 Opened 2 years ago Closed 4 months ago

Support recipes for password generation requirements

Categories

(Toolkit :: Password Manager, task, P3)

task

Tracking

()

RESOLVED DUPLICATE of bug 1686071
Tracking Status
firefox70 --- wontfix
firefox71 --- wontfix

People

(Reporter: MattN, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: parity-safari, Whiteboard: [passwords:generation])

For site which don't use appropriate minlength, maxlength or pattern attributes but have special requirements we can provide recipes to override our generated password format:

  • minimum length
  • maximum length
  • allowed characters
  • Sites it should be disabled on
  • etc.

See Apple's WBSAutofillQuirks.plist (2018 copy) for an example.

Apple has open sourced their recipes for this under an MIT license: https://github.com/apple/password-manager-resources#password-rules

Blocks: 1691664
See Also: → 1691741
Blocks: 1691741
See Also: 1691741
No longer blocks: 1691664, 1691741
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1686071
You need to log in before you can comment on or make changes to this bug.