Closed Bug 1583582 Opened 11 months ago Closed 10 months ago

mach bootstrap fails on arch linux

Categories

(Firefox Build System :: Bootstrap Configuration, defect)

defect
Not set
normal

Tracking

(firefox71 fixed)

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: greyson.gilbert.oss, Assigned: kennylevinsen)

References

(Regression)

Details

Attachments

(2 files)

Attached file os-release

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

run mach bootstrap on arch linux

Actual results:

KeyError: u'VERSION_ID' at https://searchfox.org/mozilla-central/source/python/mozboot/mozboot/bootstrap.py#260

VERSION_ID is an optional field and arch doesn't supply it.

Expected results:

Script should run successfully.

Looks like bug 1581921 introduced this

Regressed by: 1581921

Uh oh, sorry about that!
Do you want to try fixing this? If not, I can try, but I don't have Arch sitting around.

Some fields of /etc/os-release are optional, so do not throw KeyError's when they're missing.

Assignee: nobody → bugzilla
Keywords: checkin-needed
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
You need to log in before you can comment on or make changes to this bug.