Closed Bug 1583653 Opened 2 years ago Closed 2 years ago

Reflowing inserts extra whitespace text leafs that shouldn't be there

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1581589

People

(Reporter: eeejay, Unassigned)

Details

Attachments

(2 obsolete files)

In two cases in which we don't create accessibles for text leafs:

  1. If a map element has a single whitespace text node, we don't create an accessible for the map element, and we don't create an accessible text leaf for its child.
  2. If a table has whitespace text nodes between its cells we don't create text leafs for them.

If either of those are reflowed, a text node is inserted as a sibling it their container. I was concerned that this was a regression from bug 686400, but I don't believe it is after some bisection and testing.

Attached patch 0001-Bug-1583653-Test-case.patch (obsolete) — Splinter Review

Test case

Comment on attachment 9095031 [details] [diff] [review]
0001-Bug-1583653-Test-case.patch

OK, the map case is valid. Table case was just a confusion.
Attachment #9095031 - Attachment is obsolete: true
Attachment #9095362 - Attachment is obsolete: true

I'm going to close this bug as a dup of bug 1581589 to simplify things.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1581589
You need to log in before you can comment on or make changes to this bug.