Closed Bug 1584187 Opened 2 years ago Closed 2 years ago

Perma bustage on builds/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp when Gecko 71 merges to Beta on 2019-10-14

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- verified

People

(Reporter: dluca, Assigned: dholbert)

References

(Regression)

Details

Attachments

(1 file)

Summary: Beta sims build bustage on builds/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp → Beta sims build bustage on builds/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp when Gecko 71 merges to Beta on 2019-10-14

[task 2019-09-26T11:34:40.788Z] 11:34:40 ERROR - /builds/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp:5706:15: error: unused variable 'disp' [-Werror,-Wunused-variable]
[task 2019-09-26T11:34:40.788Z] 11:34:40 INFO - const auto* disp = computedStyle->StyleDisplay();

Summary: Beta sims build bustage on builds/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp when Gecko 71 merges to Beta on 2019-10-14 → Perma bustage on builds/worker/workspace/build/src/layout/base/nsCSSFrameConstructor.cpp when Gecko 71 merges to Beta on 2019-10-14

Thanks for the heads-up.

I've got a trivial patch (with mozilla::Unused). Just testing locally and then I'll post.

Flags: needinfo?(dholbert)
Assignee: nobody → dholbert
Status: NEW → ASSIGNED

The patch is at https://phabricator.services.mozilla.com/D47319 , though it's stuck in a draft state right now (which is why it hasn't appeared on the bug yet), due to some temporary phabricator issues.

Pushed by dholbert@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/70ff507dae3b
Pass an assertion-only variable to mozilla::Unused, to fix non-nightly opt build error. r=mats
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.