Closed Bug 1584696 Opened 5 years ago Closed 1 year ago

clang-format messed up various macros in nsISupportsImpl.h

Categories

(Developer Infrastructure :: Lint and Formatting, defect, P3)

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: bzbarsky, Assigned: Sylvestre)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 obsolete file)

I was trying to read some of the CC macros and not making sense of them, until I realized that the formatting was just all screwed up. Looking at https://searchfox.org/mozilla-central/diff/265e6721798a455604328ed5262f430cfcc37c2f/xpcom/base/nsISupportsImpl.h#503-516 here, for example...

There's various other stuff in that file that also got formatted pretty weirdly.

Bugbug thinks this bug is a defect, but please change it back in case of error.

Type: task → defect
Assignee: nobody → sledru

This is because clang-format isn't aware that it is a macro. By adding ";", it helps clang-format doing a better job

Priority: -- → P3
Attachment #9097338 - Attachment is obsolete: true
Has Regression Range: --- → yes
Product: Firefox Build System → Developer Infrastructure
Severity: normal → S3
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: