Closed Bug 1584827 Opened 1 year ago Closed 1 year ago

Port some changes to search bar bindings to SeaMonkey

Categories

(SeaMonkey :: Search, defect)

defect
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 fixed, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.68
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- fixed
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Details

(Whiteboard: SM2.53.1)

Attachments

(1 file)

Port the following:

  • Bug 903274 - have the search bar binding's initialization callback bail out if the binding is destroyed
  • Bug 960864 - Implement the _initialized flag instead of _addedObserver and the half-broken _destroyed

[Approval Request Comment]
Regression caused by (bug #): Bug 780179
User impact if declined: None, just works better behind the scenes
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): None
String changes made by this patch: None

Attachment #9097212 - Flags: review?(frgrahl)
Attachment #9097212 - Flags: approval-comm-release?
Attachment #9097212 - Flags: approval-comm-esr60?
Comment on attachment 9097212 [details] [diff] [review]
Port changes to search bar bindings

LGTM
Attachment #9097212 - Flags: review?(frgrahl)
Attachment #9097212 - Flags: review+
Attachment #9097212 - Flags: approval-comm-release?
Attachment #9097212 - Flags: approval-comm-release+
Attachment #9097212 - Flags: approval-comm-esr60?
Attachment #9097212 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/4f7c6fb76db0
Port some changes to search bar bindings to SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Whiteboard: SM2.53.1
You need to log in before you can comment on or make changes to this bug.