Closed Bug 1585109 Opened 2 months ago Closed 2 months ago

Crash in [@ memcpy | AString::ConvertToBSTR]

Categories

(Core :: Printing: Output, defect, critical)

All
Windows
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr60 --- wontfix
firefox-esr68 --- fixed
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- fixed
firefox70 + fixed
firefox71 --- fixed

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-a5414e28-c10b-4b80-a65a-68f830190930.

Top 10 frames of crashing thread:

0 msvcrt.dll memcpy 
1 jscript.dll AString::ConvertToBSTR 
2 jscript.dll PrepareInvoke 
3 jscript.dll VAR::InvokeByName 
4 jscript.dll VAR::InvokeByDispID 
5 jscript.dll CScriptRuntime::Run 
6 jscript.dll ScrFncObj::CallWithFrameOnStack 
7 jscript.dll ScrFncObj::Call 
8 jscript.dll NameTbl::InvokeInternal 
9 jscript.dll VAR::InvokeByDispID 

this crash signature related to printing is s starting to show up across channels from users on windows since a couple of days.

Crash Signature: [@ memcpy | AString::ConvertToBSTR] → [@ memcpy | AString::ConvertToBSTR] [@ AString::ConvertToBSTR] [@ memcpy | AString::CopyToBuffer] [@ AString::CopyToBuffer]

Hi Bob, do you have any thoughts on what might be happening?

(In reply to Ryan VanderMeulen [:RyanVM] from comment #1)

Hi Bob, do you have any thoughts on what might be happening?

I don't I'm afraid, sorry.
Given how far down into Microsoft code this is and the cross channel nature, I guess we should contact them.

Flags: needinfo?(bobowencode)

I wonder if this issue is related:
https://docs.microsoft.com/en-gb/windows/release-information/status-windows-10-1903#351msgdesc

The print spooler service may intermittently have issues completing a print job and may result in a print job being canceled or failing. Some apps may close or error when the print spooler fails and you may receive a remote procedure call error (RPC error) from some printing utility or printing apps.

Microsoft released a patch today which addresses the printing regression:
https://support.microsoft.com/en-us/help/4524147/windows-10-update-kb4524147

Addresses an intermittent issue with the print spooler service that may cause print jobs to fail. Some apps may close or generate errors, such as the remote procedure call (RPC) error.

We'll see if this drops over over the next days as that patch makes its way out there. That said, we still may want to investigate if there's anything that can be done to make Firefox more resilient to these kinds of OS-level issues in the future.

[Tracking Requested - why for this release]:
so far, the crash volume is only getting worse unfortunately. this crash is accounting for over 10% of browser crashes in 69.0.2.

Waiting for reply from Microsoft.

Just built a new office PC with a fresh install of windows 10 build 1903 (the latest ISO from the ms even though 1909 is generally available).
And I'm also experiencing this problem.

It will crash probably 9/10 times I try to print. Doesn't seem to matter which site I am printing, whether in safe mode, or normal and no extensions, or in private with no extensions.

I'm even experiencing some trouble printing from Microsoft access.

Naturally I did check windows update and install everything available after I brought it online. I do see kb4524147 in the list. So I uninstalled that update and it SEEMS that I am no longer crashing in Firefox, or having issues printing in Microsoft Access.

So, temporary solution possibly to uninstall kb4524147.

I have a lot more orders I need to print and stuff. So I'll report back as the day continues, but for now this is a huge load off my shoulders.

thanks robbieb, would you be willing to let some engineers from microsoft access the minidump of this crash report for further investigation?

Flags: needinfo?(robbieb)

FYI, we were able to share some dumps with Microsoft. They got back to us today saying that today's Patch Tuesday updates should resolve the crash. Fingers crossed!

From today's release notes:
https://support.microsoft.com/en-us/help/4517389/windows-10-update-kb4517389

Addresses an issue with applications and printer drivers that utilize the Windows JavaScript engine (jscript.dll) for processing print jobs.

(In reply to [:philipp] from comment #9)

thanks robbieb, would you be willing to let some engineers from microsoft access the minidump of this crash report for further investigation?

If more are needed, I can absolutely help. Just not sure how to send it. Hopefully the link Ryan VanderMeulen [:RyanVM] posted means that this issue is resolved. However, I think I will be waiting just a hair longer before before installing any suggested updates. Plus, kb4517389 isn't showing up for me yet anyway.

Flags: needinfo?(robbieb)

thanks robbie. the first indication we have in early crash data from installations with the win10 october patch applied (OS Build 18362.418) looks like this printing crash is indeed solved, so no further help may be required at this point :-)

i'll take a look in a couple of days again and close the bug if the situation is still looking good.

crash data is still looking good: https://bit.ly/2MuPVtc - the problem got resolved through microsoft's kb4517389 patch.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
See Also: → 1543873
You need to log in before you can comment on or make changes to this bug.