Closed Bug 1585487 Opened 10 months ago Closed 10 months ago

[Protections Panel] Update info message animation

Categories

(Firefox :: Site Identity, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox71 --- fixed

People

(Reporter: nhnt11, Assigned: nhnt11)

References

(Blocks 1 open bug)

Details

(Whiteboard: [privacy-panel][skyline])

Attachments

(2 files, 1 obsolete file)

Eric says we should eliminate motion for the text and have the panel contents slide down to reveal the info message already in place. And as this happens, fade in the info message contents from 0 opacity to 100%.

This is what it looks like - but I updated the patch after this recording so take it with a grain of salt. I also updated the header gradient to end at the edge of the panel rather than the bottom corner - since the bottom corner is now variable. This way, the gradient won't seem to change when the info message is opened.

this looks great, thanks Nihanth! Excited to see it in nightly!

Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/05273fba6dad
Update protections panel info message animation. r=johannh
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Comment on attachment 9097811 [details]
Bug 1585487 - Update protections panel info message animation. r=andreio,johannh

Beta/Release Uplift Approval Request

  • User impact if declined: Excessive motion in the animation of the Protections Panel info message.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Visual polish - CSS only. Verified via screen recording (comment 2 and comment 3)
  • String changes made/needed:
Attachment #9097811 - Flags: approval-mozilla-beta?

Comment on attachment 9097811 [details]
Bug 1585487 - Update protections panel info message animation. r=andreio,johannh

Clearing approval request due to a regression.

Attachment #9097811 - Flags: approval-mozilla-beta?
Regressions: 1587316

Comment on attachment 9099777 [details]
Bug 1585487 - Revert info message animation change. r=johannh

Revision D48641 was moved to bug 1587316. Setting attachment 9099777 [details] to obsolete.

Attachment #9099777 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.