Closed Bug 1585499 Opened 4 months ago Closed 3 months ago

Enable Extension Storage actor in Addon Debugger Toolbox by default

Categories

(WebExtensions :: Storage, task, P1)

task

Tracking

(relnote-firefox 70+, firefox70+ verified, firefox71 verified)

VERIFIED FIXED
mozilla71
Tracking Status
relnote-firefox --- 70+
firefox70 + verified
firefox71 --- verified

People

(Reporter: bdanforth, Assigned: bdanforth)

References

Details

(Keywords: dev-doc-needed)

Attachments

(1 file)

Bug 1542035 added the ability to inspect WebExtension storage.local API data from the Storage panel of the WebExtension Addon Debugger Toolbox, but the feature is gated behind the devtools.storage.extensionStorage.enabled pref which is currently false by default.

After we receive final QA approval for Bug 1542035, the feature should be enabled by default by setting devtools.storage.extensionStorage.enabled to true.

Assignee: nobody → bdanforth
Depends on: 1542035

assigned with patch, getting off our triage by setting priority.

Priority: -- → P1
Keywords: checkin-needed

Pushed by dvarga@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6f974dd99f93
Enable Extension Storage actor in addon debugger by default r=rpl,miker

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Comment on attachment 9097833 [details]
Bug 1585499 - Enable Extension Storage actor in addon debugger by default

Beta/Release Uplift Approval Request

  • User impact if declined: Without this patch, users will not be able to view the WebExtensions API browser.storage.local data in the DevTools Addon toolbox by default. They would have to flip the pref devtools.storage.extensionStorage.enabled to true in about:config first.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: (These STR are based on those from https://bugzilla.mozilla.org/show_bug.cgi?id=1542035#c8, in the section titled "Try out a real world extension and modify some of its settings kept in storage local".)
  1. In a new Firefox profile in Nightly, go to about:config and verify that the preference devtools.storage.extensionStorage.enabled is set to true.
  2. Download Tree Style Tab from https://addons.mozilla.org/en-US/firefox/addon/tree-style-tab/ .
  3. Open the addon toolbox for Tree Style Tab in about:debugging. Note: Be sure to click "Inspect" for the extension under the "Extensions" section as opposed to one of the extension pages under the "Tabs" section.
  4. Select the Storage panel, and select the extension under "Extension Storage" in the sidebar and note the storage items present.
  • For version 3.1.8, you should see something like below:
    • closeParentBehaviorMode: 1
    • configsVersion: 7
    • notifiedFeaturesVersion: 3
  • The value for the "Storage Area" column for all storage items should be local.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The actual feature (implemented by Bug 1542035 and landed in Firefox 70) has been successfully QA-verified in Beta 70 and has automated test coverage. This specific patch is small and only changes the default value of the preference to enable the feature by default.
  • String changes made/needed: No
Attachment #9097833 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9097833 [details]
Bug 1585499 - Enable Extension Storage actor in addon debugger by default

This has been in 70 since September, had an intent to ship sent, has QA verification and signoff on the feature. It also only will affect dev tools users who are debugging extensions.
Let's uplift for the RC build, so it'll be enabled by default on release.

Attachment #9097833 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Can you suggest a release note?

Flags: needinfo?(bdanforth)

lizzard: Sure. Here's the release note. By the way, this feature is for Desktop only, so please only include it in the Firefox Desktop release notes. Thank you!

WebExtensions developers can now inspect browser.storage.local data using the "Addon Debugging" Firefox Developer Tools.

Flags: needinfo?(bdanforth)

Verified fixed on Windows Pro 10 64-bit and macOS Catalina10.15 on Firefox Nightly 71.0a1 (20191014213051) and Beta 70.0b15 (20191014032640) unbranded.
The extension is enabled as true in about:config. When installing an extension like Tree Style Tab and inspecting it in about:debugging, the extension storage actor is listed in the Storage area.
When the preference is disabled (turned to false) and the browser is restarted, then the extension storage is not listed and it will not show up when increasing the extension’s permissions either.
Verified this using the latest test extensions provided as well.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.